aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vifm
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-05-24 15:23:52 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-05-25 23:23:25 +0200
commita48231db7688d5fdf5fe5927459cbde4738cea4a (patch)
tree47d5d50ccff4a940a90cb540d24f08ac27f79293 /testing/vifm
parent26be84606c0738a632843e3b3363fa1e433d2c13 (diff)
downloadaports-a48231db7688d5fdf5fe5927459cbde4738cea4a.tar.bz2
aports-a48231db7688d5fdf5fe5927459cbde4738cea4a.tar.xz
testing/vifm: new aport
Diffstat (limited to 'testing/vifm')
-rw-r--r--testing/vifm/APKBUILD43
-rw-r--r--testing/vifm/perl-interpreter-fix.patch19
2 files changed, 62 insertions, 0 deletions
diff --git a/testing/vifm/APKBUILD b/testing/vifm/APKBUILD
new file mode 100644
index 0000000000..59068f0c94
--- /dev/null
+++ b/testing/vifm/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=vifm
+pkgver=0.10
+pkgrel=0
+pkgdesc="ncurses vi-like file manager"
+url="http://vifm.info/"
+arch="all"
+license="GPL-2.0-or-later"
+depends=""
+makedepends="ncurses-dev coreutils mdocml"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vifm/$pkgname/archive/v$pkgver.tar.gz
+ perl-interpreter-fix.patch"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-X11 \
+ --without-gtk \
+ --disable-build-timestamp
+ make
+}
+
+check() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f1615f91df23cd59df4271016f84db26a481813f969957859d69c740b6c0d9410352f056d9e19881fc206300892e67481a935e16a35167bcd3bd4fd7542b031d vifm-0.10.tar.gz
+9aa55e00be8b8305184f16d76cb61cfc16ee90772c69c52d1b740f1fddbc2f7ea63a3586a0269c6bd6f5c5209c0956bec3a0c0094dc2a693390cde4c63ffa8d6 perl-interpreter-fix.patch"
diff --git a/testing/vifm/perl-interpreter-fix.patch b/testing/vifm/perl-interpreter-fix.patch
new file mode 100644
index 0000000000..acafb090af
--- /dev/null
+++ b/testing/vifm/perl-interpreter-fix.patch
@@ -0,0 +1,19 @@
+Description: Use /usr/bin/perl as Perl interpreter
+Author: Ondřej Nový <onovy@debian.org>
+
+--- a/src/vifm-convert-dircolors
++++ b/src/vifm-convert-dircolors
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env perl
++#!/usr/bin/perl
+
+ # vifm
+ # Copyright (C) 2015 xaizek.
+--- a/src/helpztags
++++ b/src/helpztags
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env perl
++#!/usr/bin/perl
+ #
+ # helpztags generates tags for Vim helpfiles, for both .txt and .txt.gz files
+ # Author: Jakub Turski <yacoob@chruptak.plukwa.net>