aboutsummaryrefslogtreecommitdiffstats
path: root/testing/virtualbox-additions-hardened/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-01-25 01:29:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-07 19:04:45 +0000
commit18e4a7f916db048f6a3418e41b757c977cc5d6a5 (patch)
tree30d674c35da9a69a728fecb3fe8cec82b8563847 /testing/virtualbox-additions-hardened/APKBUILD
parent92c19596a494fdc9ee025ec071a7394adea00d4b (diff)
downloadaports-18e4a7f916db048f6a3418e41b757c977cc5d6a5.tar.bz2
aports-18e4a7f916db048f6a3418e41b757c977cc5d6a5.tar.xz
testing/virtualbox-additions-vanilla: replace the hardened
Diffstat (limited to 'testing/virtualbox-additions-hardened/APKBUILD')
-rw-r--r--testing/virtualbox-additions-hardened/APKBUILD70
1 files changed, 0 insertions, 70 deletions
diff --git a/testing/virtualbox-additions-hardened/APKBUILD b/testing/virtualbox-additions-hardened/APKBUILD
deleted file mode 100644
index 9e3f834538..0000000000
--- a/testing/virtualbox-additions-hardened/APKBUILD
+++ /dev/null
@@ -1,70 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
-_flavor=hardened
-_kpkg=linux-$_flavor
-_kver=4.9.73
-_kpkgrel=0
-
-# when chaning _ver we *must* bump _mypkgrel
-_ver=5.1.26
-_mypkgrel=0
-_name=virtualbox-additions
-
-
-_kpkgver="$_kver-r$_kpkgrel"
-_abi_release=${_kver}-${_kpkgrel}-${_flavor}
-
-pkgname=${_name}-${_flavor}
-pkgver=$_kver
-pkgrel=$(($_kpkgrel + $_mypkgrel))
-pkgdesc="Virtual box additions kernel modules for $_flavor"
-arch="x86 x86_64"
-url='http://virtualbox.org'
-license="GPL custom"
-depends="${_kpkg}=${_kpkgver}"
-makedepends="linux-${_flavor}-dev"
-provides="${_name}-grsec=${pkgver}-r${pkgrel}"
-source="http://dev.gentoo.org/~polynomial-c/virtualbox/vbox-kernel-module-src-$_ver.tar.xz
- virtualbox-modules-4.1.4-pax-const.patch
- "
-
-builddir="$srcdir"/
-
-prepare() {
- # verify the kernel version
- (
- _kapkbuild="$startdir"/../../main/linux-${_flavor}/APKBUILD
- if [ -f $_kapkbuild ]; then
- . $_kapkbuild
- pkgname=$_name-$_flavor
- if [ "$_kver" != "$pkgver" ]; then
- die "please update _kver to $pkgver"
- fi
- if [ "$_kpkgrel" != "$pkgrel" ]; then
- die "please update _kpkgrel to $pkgrel"
- fi
- fi
- ) || return 1
-
- cd "$builddir"
- default_prepare || return 1
-}
-
-build() {
- cd "$builddir"
- export KERN_DIR=/usr/src/linux-headers-${_abi_release}
- make
-}
-
-package() {
- local module=
- cd "$builddir"
- for module in *.ko; do
- install -D -m644 $module \
- "$pkgdir/lib/modules/${_abi_release}/misc/$module" \
- || return 1
- done
-}
-
-sha512sums="c77e0d8dfade2abac95162e7e7a424be4875e44d43bcf2a13e0e50caa69f5fd0d21c77f03bb2cd4cbd5df4ab31e9fbd49ecd9220a49af8cd10081b960e014010 vbox-kernel-module-src-5.1.26.tar.xz
-9a9a982defed6d4453bc6d9388c3a71169bba85568cfd36d0d2588dda8e213a0d759c983a337a150d17c55bb6206e43738dfd2559fedeb85e132363936a48574 virtualbox-modules-4.1.4-pax-const.patch"