aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vlc-htsp-plugin
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-04-07 20:46:15 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-04-07 20:46:15 +0200
commit8f0450fe96fa559b54e3d5c64f3d05962f7b5979 (patch)
treefed2c9711b39e223d97548a8f379652cb2416b88 /testing/vlc-htsp-plugin
parent6c59d11a640e3d38c9b4c6371c97385cc1a575d5 (diff)
downloadaports-8f0450fe96fa559b54e3d5c64f3d05962f7b5979.tar.bz2
aports-8f0450fe96fa559b54e3d5c64f3d05962f7b5979.tar.xz
testing/vlc-htsp-plugin: new aport
Diffstat (limited to 'testing/vlc-htsp-plugin')
-rw-r--r--testing/vlc-htsp-plugin/APKBUILD46
-rw-r--r--testing/vlc-htsp-plugin/support-bb-install.patch11
2 files changed, 57 insertions, 0 deletions
diff --git a/testing/vlc-htsp-plugin/APKBUILD b/testing/vlc-htsp-plugin/APKBUILD
new file mode 100644
index 0000000000..c8223299de
--- /dev/null
+++ b/testing/vlc-htsp-plugin/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=vlc-htsp-plugin
+pkgver=20140304
+_id=9beb30a2d77e9d11f26e2868eca134e6734abb2e
+pkgrel=0
+pkgdesc="Plugin for VLC to access TVHeadend via HTSP"
+url="https://github.com/BtbN/vlc-htsp-plugin"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="vlc-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/BtbN/vlc-htsp-plugin/archive/$_id.tar.gz
+ support-bb-install.patch"
+
+_builddir="$srcdir"/$pkgname-$_id
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d6c04c3ea63d1ffd5e41b04d72d91090 vlc-htsp-plugin-20140304.tar.gz
+c54a463f5a153ad537803f69af479ff6 support-bb-install.patch"
+sha256sums="e02b4544b62b4a11f0299e677497735dfda755002ce709ee74777631bd2e2e87 vlc-htsp-plugin-20140304.tar.gz
+27caf87352c10b3a0cc804cb9cdd8a27afba986df5b36576513683d9f12f32ac support-bb-install.patch"
+sha512sums="cf5cfc01760f388fcd754c57c3c397ddd95c81caaa8283922ddd0789166e59fe8a128bd755a2eb3bda19874ad18fa71795f26eab8e6454693018535364b6fb47 vlc-htsp-plugin-20140304.tar.gz
+655bee8c2cd1deaee0cef100dfdb8aa29d27eae6e21b431915eafab4786aaae6b231a69a31397fa58ef98b8839f9df42091a61311da8e8543f8f6313c8403267 support-bb-install.patch"
diff --git a/testing/vlc-htsp-plugin/support-bb-install.patch b/testing/vlc-htsp-plugin/support-bb-install.patch
new file mode 100644
index 0000000000..af013800d3
--- /dev/null
+++ b/testing/vlc-htsp-plugin/support-bb-install.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.orig
++++ b/Makefile
+@@ -30,7 +30,7 @@
+
+ install: all
+ mkdir -p -- $(DESTDIR)$(plugindir)/access
+- $(INSTALL) --mode 0755 libhtsp_plugin.so $(DESTDIR)$(plugindir)/access
++ $(INSTALL) -m 0755 libhtsp_plugin.so $(DESTDIR)$(plugindir)/access
+
+ install-strip:
+ $(MAKE) install INSTALL="$(INSTALL) -s"