aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vulkan-tools
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-02 16:00:15 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-04 00:31:51 -0300
commit671ff829cd33fcb93c2e585c68112107ae388b55 (patch)
tree8104d635fded2477225fdd58badfb29471674e02 /testing/vulkan-tools
parent494f1f3bd8150ad9f1ce3e8d1162c73c062ec651 (diff)
downloadaports-671ff829cd33fcb93c2e585c68112107ae388b55.tar.bz2
aports-671ff829cd33fcb93c2e585c68112107ae388b55.tar.xz
testing/vulkan-tools: new aport
https://www.khronos.org/vulkan Vulkan Utilities and Tools
Diffstat (limited to 'testing/vulkan-tools')
-rw-r--r--testing/vulkan-tools/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/vulkan-tools/APKBUILD b/testing/vulkan-tools/APKBUILD
new file mode 100644
index 0000000000..a79c2a2487
--- /dev/null
+++ b/testing/vulkan-tools/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=vulkan-tools
+_pkgname=Vulkan-Tools
+pkgver=1.1.112
+pkgrel=0
+arch="all"
+url="https://www.khronos.org/vulkan"
+pkgdesc="Vulkan Utilities and Tools"
+license="Apache-2.0"
+depends="vulkan-loader"
+makedepends="cmake python3 libx11-dev wayland-dev vulkan-headers vulkan-loader-dev glslang-dev libxrandr-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/khronosgroup/$pkgname/archive/v$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_DATADIR=/usr/share \
+ -DCMAKE_SKIP_RPATH=True \
+ -DBUILD_CUBE=ON \
+ -DBUILD_VULKANINFO=ON \
+ -DGLSLANG_INSTALL_DIR=/usr
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="adc89c20951d86f8b017e9668588b87891a23e5a5a34ebb5cfda0701a2e37f198c979f7a48a7003001ecf8b158f0b9dfd5b00d73487a81ece996dfe632829795 vulkan-tools-1.1.112.tar.gz"