aboutsummaryrefslogtreecommitdiffstats
path: root/testing/watchexec
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-10-29 22:30:52 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-30 11:57:20 -0300
commit93e6b46a21353dcefd6e80a5078ebe78922bf996 (patch)
treef0aaa40a0f77ab73fbff4ff15d5b27ef84dbf981 /testing/watchexec
parentdfd9c13746dd0054d82a9e8c22fc08f1a95b115c (diff)
downloadaports-93e6b46a21353dcefd6e80a5078ebe78922bf996.tar.bz2
aports-93e6b46a21353dcefd6e80a5078ebe78922bf996.tar.xz
testing/watchexec: upgrade to 1.11.1
Provide zsh completion subpackage.
Diffstat (limited to 'testing/watchexec')
-rw-r--r--testing/watchexec/APKBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/testing/watchexec/APKBUILD b/testing/watchexec/APKBUILD
index 94161d5e21..269229c689 100644
--- a/testing/watchexec/APKBUILD
+++ b/testing/watchexec/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Chloe Kudryavtsev <toast@toastin.space>
# Maintainer: Chloe Kudryavtsev <toast@toastin.space>
pkgname=watchexec
-pkgver=1.10.3
+pkgver=1.11.1
pkgrel=0
pkgdesc='Executes commands in response to file modifications'
url='https://github.com/watchexec/watchexec'
arch='x86_64 x86 armhf armv7 aarch64 ppc64le' # limited by rust/cargo
license='Apache-2.0'
makedepends='cargo'
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/watchexec/watchexec/archive/$pkgver.tar.gz"
+subpackages="$pkgname-doc
+ $pkgname-zsh-completion:zshcomp:noarch"
+source="watchexec-$pkgver.tar.gz::https://github.com/watchexec/watchexec/archive/$pkgver.tar.gz"
export CARGO_HOME="$srcdir"/cargo
@@ -25,8 +26,18 @@ check() {
--verbose
}
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completion for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir"/completions/zsh \
+ "$subpkgdir"/usr/share/zsh/site-functions/_watchexec
+}
+
package() {
install -Dm755 target/release/"$pkgname" "$pkgdir"/usr/bin/"$pkgname"
install -Dm644 doc/"$pkgname".1 "$pkgdir"/usr/share/man/man1/"$pkgname".1
}
-sha512sums="5029df9b4ea801bce4bbd2cc097566d55f94cbcc377cf99609898c8e42b9522eb5c61df7952cf8d0330c03b85a43f4394c86c8ac97844fca3967670b9b733e51 watchexec-1.10.3.tar.gz"
+
+sha512sums="a8695e6c23f06459279a6bb3b64dda0956b1a3072f2d067098b72b786cefc4e480e5be35b16b473095908dc371c69c75728c9e3c5fc3dee7ddc56f903049bf97 watchexec-1.11.1.tar.gz"