aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wayland-protocols
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-06-01 10:52:04 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-06-01 10:52:04 +0200
commit7147ed96861df5ae682188dd25b3e72ee09301a0 (patch)
tree5a6c810d03338e665f5e033bc4880e18bea326f0 /testing/wayland-protocols
parent821bf23c75dffdef3bd9085c19344fe38c979a5a (diff)
downloadaports-7147ed96861df5ae682188dd25b3e72ee09301a0.tar.bz2
aports-7147ed96861df5ae682188dd25b3e72ee09301a0.tar.xz
testing/wayland-protocols: new aport
Diffstat (limited to 'testing/wayland-protocols')
-rw-r--r--testing/wayland-protocols/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/wayland-protocols/APKBUILD b/testing/wayland-protocols/APKBUILD
new file mode 100644
index 0000000000..2b73778925
--- /dev/null
+++ b/testing/wayland-protocols/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=wayland-protocols
+pkgver=1.4
+pkgrel=0
+pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
+url="http://wayland.freedesktop.org"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="wayland-dev"
+install=""
+subpackages=""
+source="https://wayland.freedesktop.org/releases/${pkgname}-${pkgver}.tar.xz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fd8089abf13a1d04e4baa6509ee72baf wayland-protocols-1.4.tar.xz"
+sha256sums="014a9a23c21ed14f49b1005b3e8efa66d6337d4ceafc97f7b0d6707e7e3df572 wayland-protocols-1.4.tar.xz"
+sha512sums="ffbac79b3be03f7b1c1033923702aadd0bdd2f90dafee946a4a2384eaa9e7f2ab90de6a6497fce374fd3343b133f8dd02683503973a65f947e65b76c47186123 wayland-protocols-1.4.tar.xz"