aboutsummaryrefslogtreecommitdiffstats
path: root/testing/weex
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2018-12-12 00:01:01 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 08:29:46 +0000
commitc4672fd3c73c7ce7d5539b2509e0a54771473368 (patch)
treec419118e9bb50bf8f2f5cb0f88754f610640df96 /testing/weex
parentf04039399781204786e376f730b8849aea59dcd2 (diff)
downloadaports-c4672fd3c73c7ce7d5539b2509e0a54771473368.tar.bz2
aports-c4672fd3c73c7ce7d5539b2509e0a54771473368.tar.xz
testing/weex: new aport
Diffstat (limited to 'testing/weex')
-rw-r--r--testing/weex/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/weex/APKBUILD b/testing/weex/APKBUILD
new file mode 100644
index 0000000000..3e80dc1dbf
--- /dev/null
+++ b/testing/weex/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Milan P. Staniić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=weex
+pkgver=2.8.3
+pkgrel=0
+pkgdesc="Non-interactive FTP and FTPS client for updating web pages"
+url="http://weex.sourceforge.net/"
+arch="all"
+license="GPL-2.0-or-later"
+depends=""
+makedepends="openssl-dev"
+install=""
+options="!check"
+subpackages="$pkgname-doc"
+source="http://http.debian.net/debian/pool/main/w/weex/weex_2.8.3.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ export CBUILD=$CHOST
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --disable-dependency-tracking \
+ --disable-nls
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0444501cebb0a01dc213ec3efe046499bcabe0e84b315806e60dcc8b96d74e3157d116eba84b2bdff6657e4997dd6b1f7e689c2098b6d45b8e06e67dd74694fa weex_2.8.3.tar.gz"