aboutsummaryrefslogtreecommitdiffstats
path: root/testing/weston
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-10-01 20:38:44 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-19 15:50:02 +0000
commit251c611ac79192324b4e5f3fe237428cb6c86ab4 (patch)
treed1caa7c05b69f84c2fdfa98fdb65d486d143b1b9 /testing/weston
parent59274c0a1bac3420d0f0db5c70d40f8457ff42a8 (diff)
downloadaports-251c611ac79192324b4e5f3fe237428cb6c86ab4.tar.bz2
aports-251c611ac79192324b4e5f3fe237428cb6c86ab4.tar.xz
testing/weston: upgrade to 1.12.0
Diffstat (limited to 'testing/weston')
-rw-r--r--testing/weston/APKBUILD20
-rw-r--r--testing/weston/musl-fixes.patch15
2 files changed, 16 insertions, 19 deletions
diff --git a/testing/weston/APKBUILD b/testing/weston/APKBUILD
index c3c9e548c6..537750c3d7 100644
--- a/testing/weston/APKBUILD
+++ b/testing/weston/APKBUILD
@@ -1,23 +1,21 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
pkgname=weston
-pkgver=1.11.0
-pkgrel=1
+pkgver=1.12.0
+pkgrel=0
pkgdesc="Reference implementation of a Wayland compositor"
url="http://wayland.freedesktop.org"
arch="x86_64 armhf"
license="MIT"
depends=""
-depends_dev=""
makedepends="wayland-protocols libxkbcommon-dev libinput-dev
libunwind-dev poppler-glib mtdev-dev libxcursor-dev
glu-dev pango-dev colord-dev"
-install=""
subpackages="$pkgname-doc"
source="http://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
musl-fixes.patch"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
./configure \
@@ -39,9 +37,9 @@ package() {
-C "$builddir" install || return 1
}
-md5sums="bc6f90a2039163804aecfa663b69c4c2 weston-1.11.0.tar.xz
-3320ff4d171f24871e789e162c76fe44 musl-fixes.patch"
-sha256sums="05e086e9f186a06843b9f7a5e1abf19347b1a6e4be26d7e74927abc17b6b7125 weston-1.11.0.tar.xz
-3cef7e810fabf6e8f476a283b7ee692e497f8557c611487fc0443cd186edd9fa musl-fixes.patch"
-sha512sums="30c43058aeca2d90d8c57ee3beb824aa42474eb2d0fa942622949b49c7771eb5d8d9c452d496a13950baabffef3c343d7386821778ae931939039fab2f782ad5 weston-1.11.0.tar.xz
-c8a923c87e5028c7446542185b34b9135a3ff8ca64a47a8ad5f3a4a86b6a34123417fc1d3b3d60cfd855977360ad91abeecd851a1bdb5848dc884cdb17bbb5a5 musl-fixes.patch"
+md5sums="310af6d7f8ba03c3418cec8ad72ea748 weston-1.12.0.tar.xz
+6f68d03829f100d358283a5714573d37 musl-fixes.patch"
+sha256sums="ac7ac2a32e3b9f50131fccded5d2326bd36b2226712d90b61999118a09af5033 weston-1.12.0.tar.xz
+03b6225fa84b52523afe571b0ec820342933e1052d87b8a8f6eb1177847ecfae musl-fixes.patch"
+sha512sums="80cf7c01951cc72b32284a5a6960c2ae7a8dfffffb155cb0f94cd3585b0afa3f06bb8e2b87467d18ab95f0fd673ad9319a6e14ee5f3cec1d3b72c7c0146c927e weston-1.12.0.tar.xz
+f9f892cdba13b1ae4d2726cfda5543364da545e725fabbf2145cd977648e84a138bb65197c604aae43a5e8415e3a58a45ec8d7a15e23eb72b7b95edefca531bc musl-fixes.patch"
diff --git a/testing/weston/musl-fixes.patch b/testing/weston/musl-fixes.patch
index 4757317fa7..00886d6d02 100644
--- a/testing/weston/musl-fixes.patch
+++ b/testing/weston/musl-fixes.patch
@@ -1,11 +1,10 @@
-diff -upr weston-1.11.0.orig/shared/xalloc.h weston-1.11.0/shared/xalloc.h
---- weston-1.11.0.orig/shared/xalloc.h 2016-06-01 10:42:27.296480970 +0200
-+++ weston-1.11.0/shared/xalloc.h 2016-06-01 10:43:01.272956869 +0200
-@@ -30,6 +30,7 @@
- extern "C" {
- #endif
+--- weston-1.12.0/shared/string-helpers.h.orig
++++ weston-1.12.0/shared/string-helpers.h
+@@ -28,6 +28,7 @@
-+#include <inttypes.h>
+ #include <stdbool.h>
#include <stdlib.h>
- #include <string.h>
++#include <stdint.h>
+ #include <errno.h>
+ #include <assert.h>