aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wf-config
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /testing/wf-config
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'testing/wf-config')
-rw-r--r--testing/wf-config/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/wf-config/APKBUILD b/testing/wf-config/APKBUILD
index b2ceb05583..2b707b1f3f 100644
--- a/testing/wf-config/APKBUILD
+++ b/testing/wf-config/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Danct12 <danct12@disroot.org>
pkgname=wf-config
pkgver=0.3
-pkgrel=0
+pkgrel=1
pkgdesc="Library for managing configuration files written for Wayfire"
url="https://wayfire.org"
arch="all"
@@ -15,7 +15,7 @@ subpackages="$pkgname-dev"
source="https://github.com/WayfireWM/wf-config/releases/download/$pkgver/wf-config-$pkgver.tar.xz"
build() {
- meson build --prefix=/usr --buildtype=release
+ meson build --prefix=/usr --buildtype=debugoptimized
}
package() {