aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wine/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-17 13:39:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-17 13:39:01 +0000
commit5c7093de598d1562a4ed4ce06eb3d14a610d19d4 (patch)
tree50285cb20ddae55c679278bc5684d6a053da1277 /testing/wine/APKBUILD
parent76c80518e2b5efa303c3a4a91edf145acca4b7a5 (diff)
downloadaports-5c7093de598d1562a4ed4ce06eb3d14a610d19d4.tar.bz2
aports-5c7093de598d1562a4ed4ce06eb3d14a610d19d4.tar.xz
testing/wine: upgrade to 1.1.38
Diffstat (limited to 'testing/wine/APKBUILD')
-rw-r--r--testing/wine/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/testing/wine/APKBUILD b/testing/wine/APKBUILD
index 82ecba1b6e..35ae36341e 100644
--- a/testing/wine/APKBUILD
+++ b/testing/wine/APKBUILD
@@ -1,23 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wine
-pkgver=1.1.36
+pkgver=1.1.38
pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc"
makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
- libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison"
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison
+ libpng-dev jpeg-dev freetype-dev"
# lcms
source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
- 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+ libpng14.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/libpng14.patch
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -Np1 -i "$srcdir"/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
- ./configure --prefix=/usr --sysconfdir=/etc --with-x
- make depend || return 1
- make || return 1
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-x
+ make depend && make
}
package() {
@@ -25,5 +32,5 @@ package() {
make prefix="$pkgdir"/usr install || return 1
mkdir -p "$pkgdir"/etc/wine
}
-md5sums="2afa7846175c7c2ce4c7482aa1d82f0f wine-1.1.36.tar.bz2
-63c4a6aee199039d35e6b57fa505e887 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+md5sums="ef5947bcb9667b75b8de4a2ce16d0ec2 wine-1.1.38.tar.bz2
+51f78b18168d5abd78411e9e66458d55 libpng14.patch"