aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wmutils
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-21 23:03:35 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-22 10:42:54 +0000
commit94fc0b0f8bcc9e197e689163d7f13518c1655d60 (patch)
tree0cd605224197486aead2ade3b68fdd41cab9e631 /testing/wmutils
parent63ccc2113467d93966fd7689044e953a4ad9f1dc (diff)
downloadaports-94fc0b0f8bcc9e197e689163d7f13518c1655d60.tar.bz2
aports-94fc0b0f8bcc9e197e689163d7f13518c1655d60.tar.xz
testing/wmutils: new aport
Diffstat (limited to 'testing/wmutils')
-rw-r--r--testing/wmutils/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/wmutils/APKBUILD b/testing/wmutils/APKBUILD
new file mode 100644
index 0000000000..e1ae9e39ca
--- /dev/null
+++ b/testing/wmutils/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=wmutils
+pkgver=1.4
+pkgrel=0
+pkgdesc="Set of X11 windows manipulation tools"
+url="https://github.com/wmutils/core"
+arch="all"
+license="ISC"
+makedepends="libxcb-dev xcb-util-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/wmutils/core/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/core-${pkgver}"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr MANPREFIX=/usr/share/man install
+}
+
+sha512sums="cdecde223e812494752d877e0e010c0cc7c1ef96e0f9aab7c517f2112f189943c84f958fb2ac4da7068ae2c5e463fe38ec783567ef980d8e63f5d299d746aee9 wmutils-1.4.tar.gz"