aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wok
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-19 10:53:04 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-19 10:53:04 +0000
commit4529845afe2cf9ef8185fc097113d861d54883b0 (patch)
treec996a66f6a99626fd3f92b7c4bbf8b8d55768878 /testing/wok
parent419f17d5c7531fac461e6bacb1643a62d46fac63 (diff)
downloadaports-4529845afe2cf9ef8185fc097113d861d54883b0.tar.bz2
aports-4529845afe2cf9ef8185fc097113d861d54883b0.tar.xz
testing/wok: upgrade to 2.4.0
Diffstat (limited to 'testing/wok')
-rw-r--r--testing/wok/APKBUILD33
-rw-r--r--testing/wok/alpine-specific-wokd.patch29
2 files changed, 22 insertions, 40 deletions
diff --git a/testing/wok/APKBUILD b/testing/wok/APKBUILD
index f91fd7eff7..6cb362d4bd 100644
--- a/testing/wok/APKBUILD
+++ b/testing/wok/APKBUILD
@@ -1,23 +1,23 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=wok
-pkgver=2.3.1
+pkgver=2.4.0
pkgrel=0
pkgdesc="Webserver of Kimchi - a cherrypy framework for multi-purpose plug-ins"
url="http://kimchi-project.github.io/wok/"
arch="noarch"
license="APACHE LGPL2.1"
depends="python2 nginx logrotate py-cherrypy py2-jsonschema
-py2-pyparted py2-pyldap py2-psutil py2-m2crypto py-cheetah
-py2-augeas py2-pam py2-functools32 py2-lxml py2-libvirt py-cherrypy
-ttf-opensans ttf-font-awesome"
+ py2-pyparted py2-pyldap py2-psutil py2-m2crypto py-cheetah
+ py2-augeas py2-pam py2-functools32 py2-lxml py2-libvirt py-cherrypy
+ ttf-opensans ttf-font-awesome"
makedepends="automake autoconf libtool gettext-dev
-python2-dev pyflakes libxslt"
-install=""
+ python2-dev pyflakes libxslt"
+options="!check"
subpackages="$pkgname-lang $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
-wokd.initd
-alpine-specific-wokd.patch"
+ wokd.initd
+ alpine-specific-wokd.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -26,23 +26,18 @@ build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --localstatedir=/var
- make || return 1
+ --localstatedir=/var \
+ --disable-rpath
+ make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m755 "$srcdir"/wokd.initd \
- "$pkgdir"/etc/init.d/wokd || return 1
+ "$pkgdir"/etc/init.d/wokd
}
-md5sums="30f6d0d2b833c3f46692c77cbe3eabd7 wok-2.3.1.tar.gz
-df0000adb91f45628ccde489fd85b9e1 wokd.initd
-63ed561751a90ca6ddb23a62a9a49e7a alpine-specific-wokd.patch"
-sha256sums="58e460d982c7b0e04d763756d6999d67bb20c8540364aa93ae9177b37270cdfb wok-2.3.1.tar.gz
-0b9d6a62e2e122943e5c59a28155d19a6acc00059d7c31d27b961d1463d62445 wokd.initd
-e896f92fc1e3c79d73068c4a5f552c945d013d87f094ae139db21cb05e0dfb84 alpine-specific-wokd.patch"
-sha512sums="120b756ee31982e78adfdfd8dbe8d6b04f6835aea96e9adc55917037bee79a9a27297500e33ab192d92fa741f702f3599b52e430665cb96f98c13c55263b90ab wok-2.3.1.tar.gz
+sha512sums="7ae1e32a621fc8b72ef66031e55e79edc21e1737325660da30d49242464940673722f09b52a38e922b7ac1aeb0e277f9a325bffe0f4a467364843165b1e8fb03 wok-2.4.0.tar.gz
a05554686e0ea2d069a5b9e9b83f6aee678ed299269d86d1192ae417ba98fa8e727d55be8f396360c70846f549f46e64028956e5f7f5c50bbf5601f548c8bd71 wokd.initd
-c47deb3ef8160162af5dbfd8b6975f86a12c69bff641ff627d4869a5edcbea8dc47551da6ee98ad5787d03a3dc93434edc42913031a19bc903a17c70a692c699 alpine-specific-wokd.patch"
+eb7a9f61d40d7edb11cc451ef25b6b2b920be23ddab7477798592bfe8a2bce8c3be21ac3d75b00d4ed3d2817af779799889fdd906d50039dec00c0c677d2c30c alpine-specific-wokd.patch"
diff --git a/testing/wok/alpine-specific-wokd.patch b/testing/wok/alpine-specific-wokd.patch
index 5f9599c3ec..b2cccedf65 100644
--- a/testing/wok/alpine-specific-wokd.patch
+++ b/testing/wok/alpine-specific-wokd.patch
@@ -1,27 +1,14 @@
-diff --git a/src/nginx/wok.conf.in b/src/nginx/wok.conf.in
-index 512b00b..116fce9 100644
---- a/src/nginx/wok.conf.in
-+++ b/src/nginx/wok.conf.in
-@@ -22,7 +22,8 @@
- # This is a template file to be used to generate a nginx
- # proxy config file at wokd script.
+diff --git a/src/nginx/wok.conf b/src/nginx/wok.conf
+index 7fadf38..560d956 100644
+--- a/src/nginx/wok.conf
++++ b/src/nginx/wok.conf
+@@ -3,7 +3,8 @@
+ # If you need to change it for any reason, please, validate /etc/wok/wok.conf
+ #
--client_max_body_size ${max_body_size}k;
+-client_max_body_size 4194304k;
+#Check nginx.conf which already have this directive
+#client_max_body_size ${max_body_size}k;
# Set timeout, based on configuration values, to avoid the 504 Gateway Timeout
# when Wok is processing a request.
-diff --git a/src/wok/proxy.py b/src/wok/proxy.py
-index 4b06fc2..15c1f8c 100644
---- a/src/wok/proxy.py
-+++ b/src/wok/proxy.py
-@@ -130,7 +130,7 @@ def start_proxy(options):
- """Start nginx reverse proxy."""
- _create_proxy_config(options)
- # Restart system's nginx service to reload wok configuration
-- cmd = ['systemctl', 'restart', 'nginx.service']
-+ cmd = ['rc-service', 'nginx', 'restart']
- output, error, retcode = run_command(cmd, silent=True)
- if retcode != 0:
- raise OperationFailed('WOKPROXY0001E', {'error': error})