aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wput/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 13:52:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 13:53:20 +0200
commit3fc2dc0f6c1c2d270b08f524ec3a08625ff14c59 (patch)
treecac1ec21a12d77a42e3677da2b1eea5b07798708 /testing/wput/APKBUILD
parente92657156e029026da489eca29c5e194843d77a3 (diff)
downloadaports-3fc2dc0f6c1c2d270b08f524ec3a08625ff14c59.tar.bz2
aports-3fc2dc0f6c1c2d270b08f524ec3a08625ff14c59.tar.xz
testing/wput: moved from unmaintained
Diffstat (limited to 'testing/wput/APKBUILD')
-rw-r--r--testing/wput/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/wput/APKBUILD b/testing/wput/APKBUILD
new file mode 100644
index 0000000000..72147f3503
--- /dev/null
+++ b/testing/wput/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=wput
+pkgver=0.6.2
+pkgrel=3
+pkgdesc="A command line tool to upload files to FTP site"
+url="http://wput.sourceforge.net/"
+arch="all"
+license="GPL2+"
+makedepends="gnutls-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tgz
+ $pkgname-destdir.patch"
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --disable-g-switch \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="a14c4c13d91d04d6119bdc977e8a8bdf wput-0.6.2.tgz
+6110908786d4b011526a6a77d6429e4f wput-destdir.patch"
+sha256sums="229d8bb7d045ca1f54d68de23f1bc8016690dc0027a16586712594fbc7fad8c7 wput-0.6.2.tgz
+fc9639d314dedd826d4543b747d8c025f188cdf15f84653e45ae4e2a4fd95639 wput-destdir.patch"
+sha512sums="e1d0fb8570cbda44c97215ee1a021a9867f2e91323b3d7f7df1d7fd68a1b2aba40a7f3068e5e85e8c736b1dba1fba62df375af99e3fb96cd0fd414b139c641bd wput-0.6.2.tgz
+d464d4395ffab7f1d8f2c0b293404b05979eb1f63600169b5344c286ecbf1209e20682c957a5319c7246d130438533f80484b30e4664e66fbc9cec6cebbb7eaf wput-destdir.patch"