aboutsummaryrefslogtreecommitdiffstats
path: root/testing/wput
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-01-07 21:55:36 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-07 21:56:06 +0100
commit34ca052cd7f9e3c8a040026f1c765dae1a1a7a62 (patch)
tree9fbefeeeb4aba7c1f927175c36e4f6a40704c118 /testing/wput
parent210f5cde905eacc2efa13bd05d9f9f6600eea269 (diff)
downloadaports-34ca052cd7f9e3c8a040026f1c765dae1a1a7a62.tar.bz2
aports-34ca052cd7f9e3c8a040026f1c765dae1a1a7a62.tar.xz
testing/wput: fix build on aarch64 - update config sub/guess
Diffstat (limited to 'testing/wput')
-rw-r--r--testing/wput/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/testing/wput/APKBUILD b/testing/wput/APKBUILD
index 72147f3503..b82ab90c4d 100644
--- a/testing/wput/APKBUILD
+++ b/testing/wput/APKBUILD
@@ -10,17 +10,14 @@ license="GPL2+"
makedepends="gnutls-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tgz
- $pkgname-destdir.patch"
-builddir="$srcdir"/$pkgname-$pkgver
+ $pkgname-destdir.patch"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- local i
+ default_prepare || return 1
+
cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ update_config_guess && update_config_sub
}
build() {