aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xbps
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-19 15:42:31 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-23 14:41:08 +0000
commit60b26fceaae273c8804f3cd23bcaf9d2a95af3bf (patch)
treeed90c3eb3a6c28b7458d4e34ea1883f8bdf71ca1 /testing/xbps
parent662b3ca683d15aec820ce66570673271230dbe72 (diff)
downloadaports-60b26fceaae273c8804f3cd23bcaf9d2a95af3bf.tar.bz2
aports-60b26fceaae273c8804f3cd23bcaf9d2a95af3bf.tar.xz
testing/xbps: new aport
Add package management of VoidLinux like pacman or dpkg to bootstrap VoidLinux.
Diffstat (limited to 'testing/xbps')
-rw-r--r--testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch44
-rw-r--r--testing/xbps/APKBUILD61
2 files changed, 105 insertions, 0 deletions
diff --git a/testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch b/testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
new file mode 100644
index 0000000000..7fb8bfdb78
--- /dev/null
+++ b/testing/xbps/46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
@@ -0,0 +1,44 @@
+From 46744c412dca9ca2efc0df8ba1473ffd9145ddac Mon Sep 17 00:00:00 2001
+From: Michael Gehring <mg@ebfe.org>
+Date: Fri, 3 Jun 2016 20:23:52 +0200
+Subject: [PATCH] lib/fetch/common.c: fix build with
+ -Werror=misleading-indentation
+
+Fixes #179
+---
+ lib/fetch/common.c | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/lib/fetch/common.c b/lib/fetch/common.c
+index 77ffb7b..dd98a88 100644
+--- a/lib/fetch/common.c
++++ b/lib/fetch/common.c
+@@ -754,17 +754,17 @@ fetch_ssl_verify_cn(X509_NAME *subject, const char *host,
+ NID_commonName, lastpos)) != -1)
+ loc = lastpos;
+
+- if (loc > -1) {
+- nameentry = X509_NAME_get_entry(subject, loc);
+- namedata = X509_NAME_ENTRY_get_data(nameentry);
+- cnlen = ASN1_STRING_to_UTF8(&cn, namedata);
+- if (ip == NULL &&
+- fetch_ssl_hname_match(host, strlen(host), (const char *)cn, cnlen))
+- ret = 1;
+- else if (ip != NULL && fetch_ssl_ipaddr_match(ip, (const char *)cn, cnlen))
+- ret = 1;
+- OPENSSL_free(cn);
+- }
++ if (loc > -1) {
++ nameentry = X509_NAME_get_entry(subject, loc);
++ namedata = X509_NAME_ENTRY_get_data(nameentry);
++ cnlen = ASN1_STRING_to_UTF8(&cn, namedata);
++ if (ip == NULL &&
++ fetch_ssl_hname_match(host, strlen(host), (const char *)cn, cnlen))
++ ret = 1;
++ else if (ip != NULL && fetch_ssl_ipaddr_match(ip, (const char *)cn, cnlen))
++ ret = 1;
++ OPENSSL_free(cn);
++ }
+ return (ret);
+ }
+
diff --git a/testing/xbps/APKBUILD b/testing/xbps/APKBUILD
new file mode 100644
index 0000000000..ac5336cab5
--- /dev/null
+++ b/testing/xbps/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+
+pkgname=xbps
+pkgver=0.51
+pkgrel=0
+pkgdesc="The X Binary Package System"
+arch="all"
+url="https://github.com/voidlinux/xbps"
+license="BSD"
+depends="ca-certificates"
+makedepends="zlib-dev libarchive-dev libressl-dev"
+subpackages="$pkgname-dev $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
+ 46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --localstatedir=/var/lib/xbps \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install || return 1
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 COPYING.3RDPARTY "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
+ mv "$pkgdir"/usr/share/bash-completion/completions/* \
+ "$subpkgdir"/usr/share/bash-completion/completions/ || return 1
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
+ mv "$pkgdir"/usr/share/zsh/site-functions/* \
+ "$subpkgdir"/usr/share/zsh/site-functions || return 1
+}
+
+sha512sums="243dbef97bd94b05af1a79605f20050d00c6dfaffa8dbc56ea0b3b2d218a627fb45f157f9f82b6eb080f58a7445de9e7bf75d669f0be4caae262af5c5ac92262 xbps-0.51.tar.gz
+1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 46744c412dca9ca2efc0df8ba1473ffd9145ddac.patch"