aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xfce4-pulseaudio-plugin
diff options
context:
space:
mode:
authorVÖRÖSKŐI András <voroskoi@gmail.com>2019-09-12 20:28:49 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-12 20:09:02 -0300
commit3dd988febdf54112e830ad049a336273dffae401 (patch)
treece5ff209111913e00ebd26a36bac6fd0c362c421 /testing/xfce4-pulseaudio-plugin
parentaf6490f1021f24c7ccf13fa2c1ebcd7ee5d488aa (diff)
downloadaports-3dd988febdf54112e830ad049a336273dffae401.tar.bz2
aports-3dd988febdf54112e830ad049a336273dffae401.tar.xz
testing/xfce4-pulseaudio-plugin: new aport
https://goodies.xfce.org/projects/panel-plugins/xfce4-pulseaudio-plugin Xfce panel plugin for pulseaudio mixer control
Diffstat (limited to 'testing/xfce4-pulseaudio-plugin')
-rw-r--r--testing/xfce4-pulseaudio-plugin/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/xfce4-pulseaudio-plugin/APKBUILD b/testing/xfce4-pulseaudio-plugin/APKBUILD
new file mode 100644
index 0000000000..ce8c27fdf8
--- /dev/null
+++ b/testing/xfce4-pulseaudio-plugin/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: VÖRÖSKŐI András <voroskoi@gmail.com>
+# Maintainer:
+pkgname="xfce4-pulseaudio-plugin"
+pkgver="0.4.2"
+pkgrel=0
+pkgdesc="Xfce panel plugin for pulseaudio mixer control."
+url="https://goodies.xfce.org/projects/panel-plugins/xfce4-pulseaudio-plugin"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="xfce4-panel-dev pulseaudio-dev libxfce4ui-dev dbus-dev dbus-glib-dev libnotify-dev"
+options="!check" # Check is empty
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/xfce4-pulseaudio-plugin/${pkgver%.*}/xfce4-pulseaudio-plugin-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="94184fe7379a7f1763d606fe3c45186767a43180329b43c8cba04b76ae5e1b2249531fc1fb6304da9bb03e7475ad65f861341253ead530d9a945165b4eb9e46e xfce4-pulseaudio-plugin-0.4.2.tar.bz2"