aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xfce4-stopwatch-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-08-21 06:38:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-21 06:38:51 +0000
commitcff9f7188ef2ac594d5bc30340f658a7b074e1b7 (patch)
treedeb2a732e92ca20fd336c30bddf80c68e146b319 /testing/xfce4-stopwatch-plugin
parent691ecba8669201978868e7a0946108e21c3b27aa (diff)
downloadaports-cff9f7188ef2ac594d5bc30340f658a7b074e1b7.tar.bz2
aports-cff9f7188ef2ac594d5bc30340f658a7b074e1b7.tar.xz
testing/xfce4-stopwatch-plugin: new aport
Stopwatch plugin for the Xfce panel https://goodies.xfce.org/projects/panel-plugins/xfce4-stopwatch-plugin
Diffstat (limited to 'testing/xfce4-stopwatch-plugin')
-rw-r--r--testing/xfce4-stopwatch-plugin/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/xfce4-stopwatch-plugin/APKBUILD b/testing/xfce4-stopwatch-plugin/APKBUILD
new file mode 100644
index 0000000000..d8dd6ce82c
--- /dev/null
+++ b/testing/xfce4-stopwatch-plugin/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname="xfce4-stopwatch-plugin"
+pkgver="0.3.1"
+pkgrel=0
+pkgdesc="Stopwatch plugin for the Xfce panel"
+url="https://goodies.xfce.org/projects/panel-plugins/xfce4-stopwatch-plugin"
+arch="all"
+license="BSD"
+makedepends="xfce4-panel-dev libxfce4ui-dev gtk+3.0-dev"
+options="!check" # no testsuite
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-stopwatch-plugin/${pkgver%.*}/xfce4-stopwatch-plugin-$pkgver.tar.bz2"
+builddir="$srcdir/xfce4-stopwatch-plugin-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f90b6728a4b0589230ccdbdc2beaebd4cde69895c68911d0417fe34a924f05612c65f0337865d5c83b28dd172c7ab56a462d60a425d5377bdbc82d69967d6860 xfce4-stopwatch-plugin-0.3.1.tar.bz2"