aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xfdashboard
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-12 14:29:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-12 14:31:21 +0000
commit35317fa51a62895de77b98f441ff35d6eaca5706 (patch)
treebaa64ae0a251c1d5f04c70fa0992413b5fbadbd2 /testing/xfdashboard
parentce858bffc820b98f0c0aac84d9468bb3b2677f70 (diff)
downloadaports-35317fa51a62895de77b98f441ff35d6eaca5706.tar.bz2
aports-35317fa51a62895de77b98f441ff35d6eaca5706.tar.xz
testing/xfdashboard: resurrect from unmaintained
Diffstat (limited to 'testing/xfdashboard')
-rw-r--r--testing/xfdashboard/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/xfdashboard/APKBUILD b/testing/xfdashboard/APKBUILD
new file mode 100644
index 0000000000..213f5b6217
--- /dev/null
+++ b/testing/xfdashboard/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfdashboard
+pkgver=0.7.4
+pkgrel=0
+pkgdesc="Maybe a Gnome shell like dashboard for Xfce"
+url="http://goodies.xfce.org/projects/applications/xfdashboard/start"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="clutter-dev xfconf-dev garcon-dev gtk+3.0-dev libwnck3-dev"
+subpackages="$pkgname-dev $pkgname-lang"
+source="http://archive.xfce.org/src/apps/${pkgname}/${pkgver%.*}/xfdashboard-${pkgver}.tar.bz2"
+
+builddir="$srcdir"/xfdashboard-"$pkgver"
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b4e6678f8c8c89e1ddbd5dffb83beebd8846053f93f456e6ab42572051bb382c6372a8356650386a433dd8662671cd6c5d01a1bd6552d8e08c2bf9aa6b54ef88 xfdashboard-0.7.4.tar.bz2"