aboutsummaryrefslogtreecommitdiffstats
path: root/testing/xulrunner
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-03 18:46:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-03 18:46:27 +0000
commitb377064f47c65a3f21faa12932a954bcbd4c3a72 (patch)
tree34afc0a86776c67effc4674c030f2cb93bd8ffe1 /testing/xulrunner
parentcc3fbab977a095013584960cdf2eb1a3e1357dbf (diff)
downloadaports-b377064f47c65a3f21faa12932a954bcbd4c3a72.tar.bz2
aports-b377064f47c65a3f21faa12932a954bcbd4c3a72.tar.xz
testing/filefox,xulrunner: dont strip binaries
so we keep debug syms
Diffstat (limited to 'testing/xulrunner')
-rw-r--r--testing/xulrunner/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
index 24e8f39297..0a7282f58f 100644
--- a/testing/xulrunner/APKBUILD
+++ b/testing/xulrunner/APKBUILD
@@ -3,7 +3,7 @@
pkgname=xulrunner
pkgver=10.0
_ffoxver=10.0
-pkgrel=1
+pkgrel=2
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -66,6 +66,7 @@ prepare() {
cp "${srcdir}/mozconfig" .mozconfig
echo "ac_add_options --enable-debug-symbols" >> .mozconfig
+ echo "ac_add_options --disable-install-strip" >>.mozconfig
}
build() {
@@ -76,7 +77,9 @@ build() {
unset CFLAGS
unset CXXFLAGS
- make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+ make -j1 -f client.mk build \
+ STRIP=/bin/true \
+ MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
}
package() {