aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ydcv
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 14:41:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 15:31:49 -0300
commit23bbbfa83cf5a840855de22868338073c1e7bc84 (patch)
tree9aae66d2bf7ca762c8d37e38b01beb4b4d76949e /testing/ydcv
parent39270bba350c7df209ca94e0ea03328905f2e965 (diff)
downloadaports-23bbbfa83cf5a840855de22868338073c1e7bc84.tar.bz2
aports-23bbbfa83cf5a840855de22868338073c1e7bc84.tar.xz
testing/ydcv: upgrade to 0.7
Diffstat (limited to 'testing/ydcv')
-rw-r--r--testing/ydcv/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/testing/ydcv/APKBUILD b/testing/ydcv/APKBUILD
index f713d093a9..fba20ede65 100644
--- a/testing/ydcv/APKBUILD
+++ b/testing/ydcv/APKBUILD
@@ -1,23 +1,25 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer: Ivan Tham <pickfire@riseup.net>
pkgname=ydcv
-pkgver=0.4
+pkgver=0.7
pkgrel=0
pkgdesc="YouDao Console Version - Chinese online translate"
url="https://github.com/felixonmars/ydcv"
arch="noarch"
-license="GPL"
-depends="" # TODO: Either python2 or python3 is needed
+license="GPL-3.0-only"
+depends="python3"
+makedepends="py3-setuptools"
subpackages="$pkgname-zsh-completion:zshcomp"
-source="$pkgname-$pkgver.tar.gz::https://github.com/felixonmars/${pkgname}/archive/${pkgver}.tar.gz"
+source="ydcv-$pkgver.tar.gz::https://github.com/felixonmars/ydcv/archive/$pkgver.tar.gz"
options="!check"
-builddir="$srcdir/"$pkgname-$pkgver
-package() {
- mkdir -p "$pkgdir"/usr/bin/$pkgname
- install -Dm755 "$builddir"/ydcv.py \
- "$pkgdir"/usr/bin/$pkgname || return 1
+build() {
+ git init
+ python3 setup.py build
+}
+package() {
+ python3 setup.py install --root="$pkgdir"
}
zshcomp() {
@@ -27,7 +29,7 @@ zshcomp() {
mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
install -Dm644 "$builddir"/contrib/zsh_completion \
- "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname || return 1
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="96c19ab8496159c90ef634533cd2f4e0a3d8a85449ae988ef0cb4d4d73e106b6383ad8c4eef5bdd0e9c7ae07db3ba2cf20112c8fa34d9487786d0cd4744f9bf3 ydcv-0.4.tar.gz"
+sha512sums="04277b2cc586bf19b0cd8cb52c0287ac75b235f72cbab19358a962f14de74f042cc90da1ec7ded06e3ce07a4694a6511599ce9213485ed0e4d40a84d296663bf ydcv-0.7.tar.gz"