aboutsummaryrefslogtreecommitdiffstats
path: root/testing/yelp-xsl/APKBUILD
diff options
context:
space:
mode:
authorAlan Lacerda <alancordeiro@gmail.com>2014-12-03 16:18:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-12-04 07:05:05 +0000
commita534704b9c477b1d4d9cee2d7704355525d17d03 (patch)
tree788437a16d6dacc7890553678e9f4b3939cfe612 /testing/yelp-xsl/APKBUILD
parented3aba6c5b35c11e2cadb4e2c3451111f58a6bcc (diff)
downloadaports-a534704b9c477b1d4d9cee2d7704355525d17d03.tar.bz2
aports-a534704b9c477b1d4d9cee2d7704355525d17d03.tar.xz
testing/yelp-xsl: new aports
Diffstat (limited to 'testing/yelp-xsl/APKBUILD')
-rw-r--r--testing/yelp-xsl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/yelp-xsl/APKBUILD b/testing/yelp-xsl/APKBUILD
new file mode 100644
index 0000000000..ef33b7df49
--- /dev/null
+++ b/testing/yelp-xsl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer:
+pkgname=yelp-xsl
+pkgver=3.14.0
+pkgrel=0
+pkgdesc="A collection of programs and data files to help you build,maintain, and distribute documentation."
+url="https://wiki.gnome.org/Apps/Yelp"
+arch="noarch"
+license="GPL/LGPL/MIT"
+depends=""
+depends_dev=""
+makedepends="intltool libxslt itstool"
+install=""
+subpackages=""
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/3.14/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="8965c1363857f223a6b761af6a37363d yelp-xsl-3.14.0.tar.xz"
+sha256sums="8f5b6793cd600f8308e4ac93da68009169fa6d590eb71ed4a8e98bafe541a87e yelp-xsl-3.14.0.tar.xz"
+sha512sums="d5f2b1b937a6b0c3f016c60be15e485d42d301446fd9b235a572a796d08481ef3f5d0df47bb5a394eb624bfe0eca650358ea1a635bbbd33e64da8e2709863483 yelp-xsl-3.14.0.tar.xz"