aboutsummaryrefslogtreecommitdiffstats
path: root/testing/yubikey-manager
diff options
context:
space:
mode:
authorDaniel Everett <deverett@gmail.com>2018-08-26 05:36:45 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 05:49:11 +0000
commit5d8a0c1b1010449a723c094cc369e5b00abe73e4 (patch)
treecc82c208164fb17e546b07d4814406becdeafdb6 /testing/yubikey-manager
parent41d8e803d40634c86459b0f173f28b85d3d0cf6c (diff)
downloadaports-5d8a0c1b1010449a723c094cc369e5b00abe73e4.tar.bz2
aports-5d8a0c1b1010449a723c094cc369e5b00abe73e4.tar.xz
testing/yubikey-manager: new aport
https://developers.yubico.com/yubikey-manager/ Python library and command line tool for configuring any YubiKey over all USB interfaces Closes GH-5058
Diffstat (limited to 'testing/yubikey-manager')
-rw-r--r--testing/yubikey-manager/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/yubikey-manager/APKBUILD b/testing/yubikey-manager/APKBUILD
new file mode 100644
index 0000000000..709c7c8639
--- /dev/null
+++ b/testing/yubikey-manager/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Daniel Everett <deverett@gmail.com>
+# Maintainer: Daniel Everett <deverett@gmail.com>
+pkgname=yubikey-manager
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="Python library and command line tool for configuring any YubiKey over all USB interfaces"
+url="https://developers.yubico.com/yubikey-manager/"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-ykman py-click py-usb py3-pyscard py-openssl py3-fido2
+ py-cryptography py-setuptools libusb ykpers-dev yubico-c pcsc-lite
+ pcsc-lite-libs"
+subpackages="py3-ykman"
+source="https://github.com/Yubico/yubikey-manager/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+ykman() {
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib
+}
+
+
+sha512sums="3e9105f1c033f9314b90cf209eb52f7879fa1ea69e9ae6dac8de0b24d7d2ff6e45b6dd530917535fa645d6eea461f5b4f23bb8deb103ffc27d1f3483cfa681c7 yubikey-manager-0.7.1.tar.gz"