aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zfs-auto-snapshot
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2020-01-13 18:44:19 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2020-01-13 18:47:23 +0100
commitb83be2a3cda486a6bdc096f147fcccbeb2eebc16 (patch)
treeb9870660ca357ed64c91fddef61950ef34cf791f /testing/zfs-auto-snapshot
parenta237104176c052399d69bbf15a40ce8c4f847c81 (diff)
downloadaports-b83be2a3cda486a6bdc096f147fcccbeb2eebc16.tar.bz2
aports-b83be2a3cda486a6bdc096f147fcccbeb2eebc16.tar.xz
testing/zfs-auto-snapshot: modernize abuild
Diffstat (limited to 'testing/zfs-auto-snapshot')
-rw-r--r--testing/zfs-auto-snapshot/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/zfs-auto-snapshot/APKBUILD b/testing/zfs-auto-snapshot/APKBUILD
index c10c9ba191..433f13df51 100644
--- a/testing/zfs-auto-snapshot/APKBUILD
+++ b/testing/zfs-auto-snapshot/APKBUILD
@@ -5,23 +5,21 @@ pkgver=1.2.4
pkgrel=1
pkgdesc="ZFS Automatic Snapshot Service for Linux"
url="https://github.com/zfsonlinux/zfs-auto-snapshot"
-arch="noarch !armhf !armv7"
+arch="noarch !armhf !armv7" # limited by zfs
license="GPL-2.0-or-later"
depends="zfs"
checkdepends="checkbashisms"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/zfsonlinux/$pkgname/archive/upstream/${pkgver}.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/zfsonlinux/zfs-auto-snapshot/archive/upstream/$pkgver.tar.gz
0001-alpine.patch
"
builddir="$srcdir/$pkgname-upstream-$pkgver"
check() {
- cd "$builddir"
checkbashisms src/zfs-auto-snapshot.sh
}
package() {
- cd "$builddir"
make install PREFIX="/usr" DESTDIR="$pkgdir"
}