aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zfs-auto-snapshot
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-10-24 09:36:43 +0200
committerHenrik Riomar <henrik.riomar@gmail.com>2018-10-24 18:57:01 +0200
commitf01677f93869c6421d66a9f40ad7a42b274be23c (patch)
treeb1976e2c2da43387d9dc095d4e4c6e6a6fba7760 /testing/zfs-auto-snapshot
parenta6c278e2f3d21e7ffc9b25ad0cd3845c3caafcf9 (diff)
downloadaports-f01677f93869c6421d66a9f40ad7a42b274be23c.tar.bz2
aports-f01677f93869c6421d66a9f40ad7a42b274be23c.tar.xz
testing/zfs-auto-snapshot: new aport
Diffstat (limited to 'testing/zfs-auto-snapshot')
-rw-r--r--testing/zfs-auto-snapshot/0001-alpine.patch40
-rw-r--r--testing/zfs-auto-snapshot/APKBUILD28
2 files changed, 68 insertions, 0 deletions
diff --git a/testing/zfs-auto-snapshot/0001-alpine.patch b/testing/zfs-auto-snapshot/0001-alpine.patch
new file mode 100644
index 0000000000..3befcf4386
--- /dev/null
+++ b/testing/zfs-auto-snapshot/0001-alpine.patch
@@ -0,0 +1,40 @@
+--- zfs-auto-snapshot-upstream-1.2.4/Makefile
++++ zfs-auto-snapshot-upstream-1.2.4-alpine/Makefile
+@@ -3,16 +3,16 @@
+ all:
+
+ install:
+- install -d $(DESTDIR)/etc/cron.d
+- install -d $(DESTDIR)/etc/cron.daily
+- install -d $(DESTDIR)/etc/cron.hourly
+- install -d $(DESTDIR)/etc/cron.weekly
+- install -d $(DESTDIR)/etc/cron.monthly
+- install -m 0644 etc/zfs-auto-snapshot.cron.frequent $(DESTDIR)/etc/cron.d/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.hourly $(DESTDIR)/etc/cron.hourly/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.daily $(DESTDIR)/etc/cron.daily/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.weekly $(DESTDIR)/etc/cron.weekly/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.monthly $(DESTDIR)/etc/cron.monthly/zfs-auto-snapshot
++ install -d $(DESTDIR)/etc/periodic/15min
++ install -d $(DESTDIR)/etc/periodic/daily
++ install -d $(DESTDIR)/etc/periodic/hourly
++ install -d $(DESTDIR)/etc/periodic/weekly
++ install -d $(DESTDIR)/etc/periodic/monthly
++ install -m 0755 etc/zfs-auto-snapshot.cron.frequent $(DESTDIR)/etc/periodic/15min/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.hourly $(DESTDIR)/etc/periodic/hourly/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.daily $(DESTDIR)/etc/periodic/daily/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.weekly $(DESTDIR)/etc/periodic/weekly/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.monthly $(DESTDIR)/etc/periodic/monthly/zfs-auto-snapshot
+ install -d $(DESTDIR)$(PREFIX)/share/man/man8
+ install src/zfs-auto-snapshot.8 $(DESTDIR)$(PREFIX)/share/man/man8/zfs-auto-snapshot.8
+ install -d $(DESTDIR)$(PREFIX)/sbin
+--- zfs-auto-snapshot-upstream-1.2.4/etc/zfs-auto-snapshot.cron.frequent
++++ zfs-auto-snapshot-upstream-1.2.4-alpine/etc/zfs-auto-snapshot.cron.frequent
+@@ -1,3 +1,6 @@
+-PATH="/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin"
++#!/bin/sh
+
+-*/15 * * * * root which zfs-auto-snapshot > /dev/null || exit 0 ; zfs-auto-snapshot --quiet --syslog --label=frequent --keep=4 //
++# Only call zfs-auto-snapshot if it's available
++which zfs-auto-snapshot > /dev/null || exit 0
++
++exec zfs-auto-snapshot --quiet --syslog --label=frequent --keep=4 //
diff --git a/testing/zfs-auto-snapshot/APKBUILD b/testing/zfs-auto-snapshot/APKBUILD
new file mode 100644
index 0000000000..6e4c04d54c
--- /dev/null
+++ b/testing/zfs-auto-snapshot/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer:
+pkgname=zfs-auto-snapshot
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="ZFS Automatic Snapshot Service for Linux"
+url="https://github.com/zfsonlinux/zfs-auto-snapshot"
+arch="noarch"
+license="GPL-2.0"
+checkdepends="checkbashisms"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zfsonlinux/$pkgname/archive/upstream/${pkgver}.tar.gz
+ 0001-alpine.patch
+ "
+builddir="$srcdir/$pkgname-upstream-$pkgver"
+
+check() {
+ cd "$builddir"
+ checkbashisms src/zfs-auto-snapshot.sh
+}
+
+package() {
+ cd "$builddir"
+ make install PREFIX="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="26382303fce8b90dfb40f69fcab92308e88c17c147b4a566c5d32f2e9aa241d64f5da56ad82b4becb824ba01a470037a724460d35676a1d46de9c578c02a57d9 zfs-auto-snapshot-1.2.4.tar.gz
+76733b98a168fa0a09452809aad5e1079cf789e5c96f5ced590b3e8d609c26b2fedc38ca0b406544825cd509f259df8e917d4b1355f8bea9942b0ca0ba872eba 0001-alpine.patch"