aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zim-tools
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /testing/zim-tools
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'testing/zim-tools')
-rw-r--r--testing/zim-tools/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/zim-tools/APKBUILD b/testing/zim-tools/APKBUILD
index 0348e34a4a..ca16d37f63 100644
--- a/testing/zim-tools/APKBUILD
+++ b/testing/zim-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=zim-tools
pkgver=1.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Various ZIM command line tools"
url="https://github.com/openzim/zim-tools"
arch="all"
@@ -20,7 +20,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release
+ --buildtype=debugoptimized
ninja -C build
}