aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zsh-syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
authordawidd6 <dawidd0811@gmail.com>2017-06-29 14:17:15 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-22 21:37:30 +0200
commit947d3f601d4f5f8a9f28e8b21fbeb743a58551ef (patch)
tree0cd1047834cbc56eed79dcf70e04eca33862c3c2 /testing/zsh-syntax-highlighting/APKBUILD
parent50395fcbaa5939969c4423e1e60737f91c6d41b6 (diff)
downloadaports-947d3f601d4f5f8a9f28e8b21fbeb743a58551ef.tar.bz2
aports-947d3f601d4f5f8a9f28e8b21fbeb743a58551ef.tar.xz
testing/zsh-syntax-highlighting: new aport
https://github.com/zsh-users/zsh-syntax-highlighting Fish shell like syntax highlighting for Zsh
Diffstat (limited to 'testing/zsh-syntax-highlighting/APKBUILD')
-rw-r--r--testing/zsh-syntax-highlighting/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/zsh-syntax-highlighting/APKBUILD b/testing/zsh-syntax-highlighting/APKBUILD
new file mode 100644
index 0000000000..8f27518cd5
--- /dev/null
+++ b/testing/zsh-syntax-highlighting/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Dawid Dziurla <dawidd0811@gmail.com>
+# Maintainer: Dawid Dziurla <dawidd0811@gmail.com>
+pkgname=zsh-syntax-highlighting
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="Fish shell like syntax highlighting for Zsh"
+url="https://github.com/zsh-users/zsh-syntax-highlighting"
+arch="noarch"
+license="BSD-3"
+depends="zsh"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # no tests
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX="/usr" \
+ SHARE_DIR="$pkgdir/usr/share/zsh/plugins/$pkgname"
+}
+
+sha512sums="dd0dcb772add597eb6f04e9958fb960688a5a2e316d51792d573fbfe1fd43e5a63c0de2242f87837818f27d732d8872576978c950640c1d1eea92b7b01ae84b4 zsh-syntax-highlighting-0.5.0.tar.gz"