aboutsummaryrefslogtreecommitdiffstats
path: root/testing/zxing-cpp/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-25 22:32:56 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-25 20:25:57 -0300
commite820c1c719027b0e46fe2f509b2b05f010aa2e93 (patch)
treed7975e3748bbe7ae3bfa33910b2e47a1ba3f4bcf /testing/zxing-cpp/APKBUILD
parent2269d32d6afaf222851f5380dc5569533d2cc750 (diff)
downloadaports-e820c1c719027b0e46fe2f509b2b05f010aa2e93.tar.bz2
aports-e820c1c719027b0e46fe2f509b2b05f010aa2e93.tar.xz
testing/zxing-cpp: new aport
Diffstat (limited to 'testing/zxing-cpp/APKBUILD')
-rw-r--r--testing/zxing-cpp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/zxing-cpp/APKBUILD b/testing/zxing-cpp/APKBUILD
new file mode 100644
index 0000000000..61ad3c71eb
--- /dev/null
+++ b/testing/zxing-cpp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=zxing-cpp
+pkgver=1.0.5
+pkgrel=0
+arch="all"
+url="https://github.com/nu-book/zxing-cpp"
+pkgdesc="C++ port of ZXing "
+license="Apache-2.0"
+makedepends="cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nu-book/$pkgname/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBRARY=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="7d50e3a597aa123ba9a71211b6096e03de71ccd15d408d08dba214df64de14d462f8d7e8a1dd094d59b8438a61f5c5c436c4d0549039c630270d509812967f65 zxing-cpp-1.0.5.tar.gz"