aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-27 09:38:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-27 09:38:29 +0000
commit955233cd4d2b5e62f9c1a41fa91e6951aa32d940 (patch)
tree1b2fc3b0aa2dafec347f3b353fffd1431c2afc8e /testing
parent12d2320c6ff39f70ca62bb2b12ed6624349a985f (diff)
downloadaports-955233cd4d2b5e62f9c1a41fa91e6951aa32d940.tar.bz2
aports-955233cd4d2b5e62f9c1a41fa91e6951aa32d940.tar.xz
testing/dahdi-linux-vserver: use prepare() and package()
Diffstat (limited to 'testing')
-rw-r--r--testing/dahdi-linux-vserver/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/dahdi-linux-vserver/APKBUILD b/testing/dahdi-linux-vserver/APKBUILD
index 1638b5f117..14c26a0078 100644
--- a/testing/dahdi-linux-vserver/APKBUILD
+++ b/testing/dahdi-linux-vserver/APKBUILD
@@ -34,15 +34,22 @@ source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realna
dahdi-2.6.31.patch
"
-build() {
+prepare() {
cd "$srcdir/$_realname-$_dahdiver"
for i in ../*.patch ../*.diff; do
msg "Applying $i"
patch -p1 < $i || return 1;
done
+}
+build() {
+ cd "$srcdir/$_realname-$_dahdiver"
make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
|| return 1
+}
+
+package() {
+ cd "$srcdir/$_realname-$_dahdiver"
make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware \