aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-14 13:15:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-14 13:15:49 +0000
commitb143467a7a236be82022878f1efcd5098145d7b9 (patch)
treee308c7da7acd8255cebde08666496e4494566cce /testing
parent1eb7653bc7e3ec77392db122910c0f4cd0f277cc (diff)
downloadaports-b143467a7a236be82022878f1efcd5098145d7b9.tar.bz2
aports-b143467a7a236be82022878f1efcd5098145d7b9.tar.xz
testing/libmpdclient: new aport
An asynchronous API library for interfacing MPD in the C, C++ & Objective C languages http://mpd.wikia.com/wiki/Client:libmpdclient
Diffstat (limited to 'testing')
-rw-r--r--testing/libmpdclient/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libmpdclient/APKBUILD b/testing/libmpdclient/APKBUILD
new file mode 100644
index 0000000000..4b43958619
--- /dev/null
+++ b/testing/libmpdclient/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmpdclient
+pkgver=2.1
+pkgrel=0
+pkgdesc="An asynchronous API library for interfacing MPD in the C, C++ & Objective C languages"
+url="http://mpd.wikia.com/wiki/Client:libmpdclient"
+license="GPL2"
+depends=
+makedepends=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/musicpd/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="67efa0c3d107c090ef277dfb3442d1e3 libmpdclient-2.1.tar.bz2"