aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-12 11:12:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-12 11:12:54 +0000
commit99d7d8fe29928dcbe72e1166424db141a13b0103 (patch)
tree6d35a906137e3bf65702f154b4bae4aa5e099142 /testing
parent924e653655223ffbb3a028f101547e4f85921f95 (diff)
downloadaports-99d7d8fe29928dcbe72e1166424db141a13b0103.tar.bz2
aports-99d7d8fe29928dcbe72e1166424db141a13b0103.tar.xz
main/mdocml: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/mdocml/APKBUILD39
-rw-r--r--testing/mdocml/man.sh52
2 files changed, 0 insertions, 91 deletions
diff --git a/testing/mdocml/APKBUILD b/testing/mdocml/APKBUILD
deleted file mode 100644
index c9dc85ac24..0000000000
--- a/testing/mdocml/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=mdocml
-pkgver=1.11.4
-pkgrel=0
-pkgdesc="mdoc/man compiler"
-url="http://mdocml.bsd.lv/"
-arch="all"
-license="BSD"
-depends=
-makedepends=
-install=
-subpackages="$pkgname-doc $pkgname-dev $pkgname-man"
-source="http://mdocml.bsd.lv/snapshots/mdocml-$pkgver.tar.gz man.sh"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-}
-
-build() {
- cd "$_builddir"
- make PREFIX=/usr || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" PREFIX=/usr MANDIR=/usr/share/man \
- EXAMPLEDIR=/usr/share/doc/mdocml/examples install
-}
-
-man() {
- cd "$srcdir"
- depends="mdocml"
- install -Dm 755 man.sh "$subpkgdir"/usr/bin/man || return 1
-}
-
-md5sums="ba8af3994706dac47ef904f0b94dc396 mdocml-1.11.4.tar.gz
-d60a6a3ea949f03e7fb90dbe1ca74e1f man.sh"
diff --git a/testing/mdocml/man.sh b/testing/mdocml/man.sh
deleted file mode 100644
index 6795e2007d..0000000000
--- a/testing/mdocml/man.sh
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/sh
-
-# man - a simple man program for ASCII pages
-# Copyright (c) 2008 Matthew Hiles
-#
-# Licensed under GPLv2 or later, see file LICENSE in this tarball for details.
-
-## requires: find, head, sort, tr, cat, and grep/egrep
-## optional: zcat, bzcat, less
-
-if [ -z "$MANPATH" ]; then
- echo "Warning: MANPATH is not set, assuming /usr/share/man." >&2
- MANPATH=/usr/share/man
-fi
-
-case $# in
-1)
- pagearg=$1 ;;
-2)
- section=man$1
- pagearg=$2 ;;
-*)
- echo "Usage: man [section] <manpage>"
- exit
-esac
-
-paths=`echo "$MANPATH" | tr ":" " "`
-pagefile=`find $paths | grep "/$section" | grep "/$pagearg\." | sort | head -n1`
-
-if [ -z "$pagefile" ]; then
- echo -n No manual entry for $pagearg
- [ $section ] && echo -n " in section $1 of the manual."
- echo
- exit
-fi
-
-[ "$PAGER" ] || PAGER=less
-tty -s <&1 || PAGER=cat
-
-case "$pagefile" in
-*.bz2)
- exec bzcat "$pagefile" | "$PAGER" ;;
-*.gz)
- exec zcat "$pagefile" | "$PAGER" ;;
-*)
- exec mandoc -Tutf8 "$pagefile" | "$PAGER" ;;
-esac
-
-paths=
-pagefile=
-pagearg=
-section=