aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-07-18 11:16:39 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-07-18 11:16:50 +0000
commitb8b4953ab03d1e94abee1410151cee80d88325ed (patch)
tree8fe0c192c7db5b3a2c4530192cd8660c912ee4e6 /testing
parent17c2a4ac28372206e74e8fa9389e7c2dffc802ac (diff)
downloadaports-b8b4953ab03d1e94abee1410151cee80d88325ed.tar.bz2
aports-b8b4953ab03d1e94abee1410151cee80d88325ed.tar.xz
testing/ocfs2-tools: new aport
Userland utils for Oracle Clustered Filesystem 2
Diffstat (limited to 'testing')
-rw-r--r--testing/ocfs2-tools/APKBUILD58
-rw-r--r--testing/ocfs2-tools/build.patch32
-rw-r--r--testing/ocfs2-tools/gcc45-ftbfs.patch21
3 files changed, 111 insertions, 0 deletions
diff --git a/testing/ocfs2-tools/APKBUILD b/testing/ocfs2-tools/APKBUILD
new file mode 100644
index 0000000000..9f9624da30
--- /dev/null
+++ b/testing/ocfs2-tools/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=ocfs2-tools
+pkgver=1.4.4
+pkgrel=0
+pkgdesc="Oracle Cluster File System 2 utilities"
+url="http://oss.oracle.com/projects/ocfs2-tools"
+arch="all"
+license="GPL2"
+depends=
+depends_dev="e2fsprogs-dev glib-dev readline-dev"
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://oss.oracle.com/projects/ocfs2-tools/dist/files/source/v1.4/$pkgname-$pkgver.tar.gz
+ gcc45-ftbfs.patch
+ build.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+
+ for i in ../*.patch
+ do
+ msg "Applying patch $i"
+ patch -p1 -i $i || return 1
+ done
+
+ sed -i 's%sys/raw.h%linux/raw.h%' fswreck/include/main.h || return 1
+ sed -i 's%sys/raw.h%linux/raw.h%' debugfs.ocfs2/include/main.h || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export LDFLAGS="$LDFLAGS -L/usr/include/linux"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-ocfs2console=no \
+ --enable-dynamic-fsck=yes \
+ --disable-glibtest
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="f7ae245e8baa499aa56d7af25a7885d5 ocfs2-tools-1.4.4.tar.gz
+5dba18ca5596b1de0f2eeb30f5ed1656 gcc45-ftbfs.patch
+c938040f0e77a4bb23e952c8f99b6cc5 build.patch"
diff --git a/testing/ocfs2-tools/build.patch b/testing/ocfs2-tools/build.patch
new file mode 100644
index 0000000000..c0e9e503ab
--- /dev/null
+++ b/testing/ocfs2-tools/build.patch
@@ -0,0 +1,32 @@
+diff -Nuard ocfs2-tools-1.4.3.orig/ocfs2_controld/Makefile ocfs2-tools-1.4.3/ocfs2_controld/Makefile
+--- ocfs2-tools-1.4.3.orig/ocfs2_controld/Makefile 2009-04-14 00:10:40.000000000 +0200
++++ ocfs2-tools-1.4.3/ocfs2_controld/Makefile 2009-09-30 08:22:04.000000000 +0200
+@@ -17,7 +17,7 @@
+ PCMK_INCLUDES = -I/usr/include/pacemaker -I/usr/include/heartbeat/ $(GLIB_CFLAGS)
+ endif
+
+-INCLUDES = -I$(TOPDIR)/include -I. $(PCMK_INCLUDES)
++INCLUDES = -I/usr/include/libxml2 -I$(TOPDIR)/include -I. $(PCMK_INCLUDES)
+ LIBO2CB_LIBS = -L$(TOPDIR)/libo2cb -lo2cb
+ LIBO2CB_DEPS = $(TOPDIR)/libo2cb/libo2cb.a
+ LIBOCFS2_LIBS = -L$(TOPDIR)/libocfs2 -locfs2
+diff -Nuard ocfs2-tools-1.4.3.orig/ocfs2_controld/pacemaker.c ocfs2-tools-1.4.3/ocfs2_controld/pacemaker.c
+--- ocfs2-tools-1.4.3.orig/ocfs2_controld/pacemaker.c 2009-05-06 03:36:57.000000000 +0200
++++ ocfs2-tools-1.4.3/ocfs2_controld/pacemaker.c 2009-09-30 08:22:22.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #include <bzlib.h>
+
++#include <corosync/corodefs.h>
+ #include <pacemaker/crm_config.h>
+ /* heartbeat support is irrelevant here */
+ #undef SUPPORT_HEARTBEAT
+@@ -155,7 +156,7 @@
+ crm_log_init("ocfs2_controld", LOG_INFO, FALSE, TRUE, 0, NULL);
+
+ if(init_ais_connection(NULL, NULL, NULL, &local_node_uname, &our_nodeid) == FALSE) {
+- log_error("Connection to our AIS plugin (%d) failed", CRM_SERVICE);
++ log_error("Connection to our AIS plugin (%d) failed", PCMK_SERVICE);
+ return -1;
+ }
+
diff --git a/testing/ocfs2-tools/gcc45-ftbfs.patch b/testing/ocfs2-tools/gcc45-ftbfs.patch
new file mode 100644
index 0000000000..0db24f49e2
--- /dev/null
+++ b/testing/ocfs2-tools/gcc45-ftbfs.patch
@@ -0,0 +1,21 @@
+diff -urN ocfs2-tools-1.4.3.orig//mount.ocfs2/mount.ocfs2.c ocfs2-tools-1.4.3/mount.ocfs2/mount.ocfs2.c
+--- ocfs2-tools-1.4.3.orig//mount.ocfs2/mount.ocfs2.c 2009-04-14 00:10:40.000000000 +0200
++++ ocfs2-tools-1.4.3/mount.ocfs2/mount.ocfs2.c 2010-03-24 07:23:45.000000000 +0100
+@@ -261,7 +261,7 @@
+ char *extra = NULL;
+ int dev_ro = 0;
+ char *hbstr = NULL;
+- char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1] = "";
++ char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1];
+ ocfs2_filesys *fs = NULL;
+ struct o2cb_cluster_desc cluster;
+ struct o2cb_region_desc desc;
+@@ -269,6 +269,8 @@
+ int hb_started = 0;
+ struct stat statbuf;
+
++ stackstr[0] = '\0';
++
+ initialize_ocfs_error_table();
+ initialize_o2dl_error_table();
+ initialize_o2cb_error_table();