aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-29 07:16:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-29 07:33:02 +0000
commitda07e62d7c1a0663d00d1057f401db5984b98e80 (patch)
tree58181a3f2b8a137f721a8d1d12887be4b582fabf /testing
parenta27df9d9787fbe1a6f22baf7e92a4a0007104384 (diff)
downloadaports-da07e62d7c1a0663d00d1057f401db5984b98e80.tar.bz2
aports-da07e62d7c1a0663d00d1057f401db5984b98e80.tar.xz
testing/xmlrpc-c: remove *.la and build fix for curl-7.21.7
Diffstat (limited to 'testing')
-rw-r--r--testing/xmlrpc-c/APKBUILD23
-rw-r--r--testing/xmlrpc-c/xmlrpc-c-curl.patch36
2 files changed, 54 insertions, 5 deletions
diff --git a/testing/xmlrpc-c/APKBUILD b/testing/xmlrpc-c/APKBUILD
index a7df7289fe..b328130a90 100644
--- a/testing/xmlrpc-c/APKBUILD
+++ b/testing/xmlrpc-c/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xmlrpc-c
-pkgver=1.06.40
-pkgrel=0
+pkgver=1.16.35
+pkgrel=1
pkgdesc="This library provides a modular implementation of XML-RPC for C and C++"
url="http://xmlrpc-c.sourceforge.net/"
arch="x86"
@@ -9,9 +9,20 @@ license="custom:xmlrpc-c"
depends=
makedepends="libtool curl-dev libxml2-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc xmlrpc-c++:cxx"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz
+ xmlrpc-c-curl.patch"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -30,8 +41,9 @@ build() {
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install || return 1
install -m 644 -D doc/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ rm -f "$pkgdir"/usr/lib/*.la
}
cxx() {
@@ -40,4 +52,5 @@ cxx() {
mv "$pkgdir"/usr/lib/*++* "$subpkgdir"/usr/lib/
}
-md5sums="684fd8b9edda6da55a58d2a18e5056c5 xmlrpc-c-1.06.40.tgz"
+md5sums="eed7ef8078800e4822d753bac9d2fa1c xmlrpc-c-1.16.35.tgz
+101c2224b2338247097f96b03e206261 xmlrpc-c-curl.patch"
diff --git a/testing/xmlrpc-c/xmlrpc-c-curl.patch b/testing/xmlrpc-c/xmlrpc-c-curl.patch
new file mode 100644
index 0000000000..bfc1145776
--- /dev/null
+++ b/testing/xmlrpc-c/xmlrpc-c-curl.patch
@@ -0,0 +1,36 @@
+diff --git a/lib/curl_transport/curlmulti.c b/lib/curl_transport/curlmulti.c
+index 526a4db..5503b9f 100644
+--- a/lib/curl_transport/curlmulti.c
++++ b/lib/curl_transport/curlmulti.c
+@@ -17,7 +17,6 @@
+ #endif
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #include <curl/multi.h>
+
+diff --git a/lib/curl_transport/curltransaction.c b/lib/curl_transport/curltransaction.c
+index 37ec02b..8fa4fb2 100644
+--- a/lib/curl_transport/curltransaction.c
++++ b/lib/curl_transport/curltransaction.c
+@@ -15,7 +15,6 @@
+ #include "version.h"
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ #include "curlversion.h"
+diff --git a/lib/curl_transport/xmlrpc_curl_transport.c b/lib/curl_transport/xmlrpc_curl_transport.c
+index 526381d..9b7b530 100644
+--- a/lib/curl_transport/xmlrpc_curl_transport.c
++++ b/lib/curl_transport/xmlrpc_curl_transport.c
+@@ -83,7 +83,6 @@
+ #include "xmlrpc-c/time_int.h"
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #include <curl/multi.h>
+