aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-17 18:05:04 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-17 18:05:59 +0200
commit446f21b2944f6415050f9119603db31f6927b8d3 (patch)
tree79942df0162c5b411705aec41bfe6249d26cfdc6 /testing
parentbbec1a59b8bf12a4b9639a82790a3445fae98c5e (diff)
downloadaports-446f21b2944f6415050f9119603db31f6927b8d3.tar.bz2
aports-446f21b2944f6415050f9119603db31f6927b8d3.tar.xz
testing/java-snappy: improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/java-snappy/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/java-snappy/APKBUILD b/testing/java-snappy/APKBUILD
index 313885addc..bfb7bb30a2 100644
--- a/testing/java-snappy/APKBUILD
+++ b/testing/java-snappy/APKBUILD
@@ -18,6 +18,8 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/xerial/$_pkgname/archive/$pk
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
+ default_prepare || return 1
+
cd "$builddir"
# Get rid of bundled native binaries.
@@ -27,8 +29,6 @@ prepare() {
cat > src/main/resources/org-xerial-snappy.properties <<-EOF
org.xerial.snappy.use.systemlib=true
EOF
-
- default_prepare
}
build() {
@@ -37,7 +37,7 @@ build() {
JAVA_HOME=/usr/lib/jvm/default-jvm \
make || return 1
- echo "Downloading SBT and then building JAR (this will take few minutes)..." >&2
+ msg "Downloading SBT and then building JAR (this will take few minutes)..."
./sbt -Dsbt.boot.directory=/tmp/sbt/boot \
-Dsbt.ivy.home=/tmp/sbt/.ivy2 \
package
@@ -45,7 +45,7 @@ build() {
package() {
arch="noarch"
- depends="$pkgname-native"
+ depends="$depends $pkgname-native"
install -m644 -D "$builddir"/target/$_pkgname-*.jar \
"$pkgdir"/usr/share/java/$_pkgname-$pkgver.jar || return 1