aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-03-17 20:51:21 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-04 06:04:24 +0000
commita921727ddc01462f09607ac7f9a91097ebae069a (patch)
tree85bbfdaa1d526dd26c9b37aaf293c1deb85d89be /testing
parent665bd30e58f61ca73749f29aa4a34ed1d4814396 (diff)
downloadaports-a921727ddc01462f09607ac7f9a91097ebae069a.tar.bz2
aports-a921727ddc01462f09607ac7f9a91097ebae069a.tar.xz
testing/py-backcall: remove python2 support
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-backcall/APKBUILD (renamed from testing/py-backcall/APKBUILD)37
1 files changed, 6 insertions, 31 deletions
diff --git a/testing/py-backcall/APKBUILD b/testing/py3-backcall/APKBUILD
index 57672f0de2..d33a940252 100644
--- a/testing/py-backcall/APKBUILD
+++ b/testing/py3-backcall/APKBUILD
@@ -1,54 +1,29 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
-pkgname=py-backcall
+pkgname=py3-backcall
pkgver=0.1.0
pkgrel=0
pkgdesc="Backwards compatible callback APIs"
url="https://github.com/takluyver/backcall"
arch="noarch"
license="BSD-3-Clause"
-makedepends="python2-dev python3-dev"
+makedepends="python3-dev"
checkdepends="pytest"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/b/backcall/backcall-$pkgver.tar.gz"
-builddir="$srcdir/${pkgname#py-}-$pkgver"
+builddir="$srcdir/${pkgname#py3-}-$pkgver"
+replaces="py-backcall"
+provides="py-backcall"
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
-
- py.test-2
py.test-3
}
package() {
- cd "$builddir"
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="359c483fbc8998fc2420daee2a6af7566c47fb03f64e465aa226589a2f98a4b219ab5e5b90e5f677087827a1ac658c02ec3062e9ffe9ac1ebfd9db3bb40339cd backcall-0.1.0.tar.gz"