aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-04-01 14:41:01 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-03 12:58:19 +0000
commitdd6a77914878ed8fd6a65e65c272ebedb557677c (patch)
tree668606c7332e10507ddc1ffa603b1e40f282ae20 /testing
parentfc11c8698819b100a2fb46ccfbaecbbc3806e46e (diff)
downloadaports-dd6a77914878ed8fd6a65e65c272ebedb557677c.tar.bz2
aports-dd6a77914878ed8fd6a65e65c272ebedb557677c.tar.xz
testing/ghex: fix makedepends (intltool), modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/ghex/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/ghex/APKBUILD b/testing/ghex/APKBUILD
index f0484d2716..4d9a130aa8 100644
--- a/testing/ghex/APKBUILD
+++ b/testing/ghex/APKBUILD
@@ -3,15 +3,14 @@
pkgname=ghex
pkgver=3.18.3
_pkgver=${pkgver%.*}
-pkgrel=0
+pkgrel=1
pkgdesc="A hex editor for GNOME"
url="https://wiki.gnome.org/Apps/Ghex"
arch="all"
license="GPL"
depends="dconf"
depends_dev="gtk+3.0-dev"
-makedepends="$depends_dev itstool libxml2-utils"
-install=""
+makedepends="$depends_dev intltool itstool libxml2-utils"
subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
source="https://download.gnome.org/sources/ghex/$_pkgver/$pkgname-$pkgver.tar.xz"
@@ -24,14 +23,13 @@ build() {
--host=$CHOST \
--prefix=/usr \
--disable-schemas-compile \
- --enable-compile-warnings=no \
- || return 1
- make || return 1
+ --enable-compile-warnings=no
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" DATADIRNAME=share install || return 1
+ make DESTDIR="$pkgdir" DATADIRNAME=share install
}
sha512sums="e03b154a22db000a5994c68bb72280113e69e7ef210f86ab2c6578e77daabf50bac8eb620ffaad5a7eb776d23383478cbdc7fb317fa336cef55173f858519023 ghex-3.18.3.tar.xz"