aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-22 16:50:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-22 16:50:01 +0100
commitf4f0638890adb80db5de3fbc772490f149ab4fbc (patch)
tree342e59cfb9c1a4a582a9834b30bc67a9f381088d /testing
parent9144c88c339320172a33a7b157e70677c1988a0d (diff)
downloadaports-f4f0638890adb80db5de3fbc772490f149ab4fbc.tar.bz2
aports-f4f0638890adb80db5de3fbc772490f149ab4fbc.tar.xz
community/hub: move to testing due to violation of QA rules
`go get` must not be used in APKBUILD. It downloads random dependencies from Internet without any verification, leads to unreproducible build.
Diffstat (limited to 'testing')
-rw-r--r--testing/hub/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/hub/APKBUILD b/testing/hub/APKBUILD
new file mode 100644
index 0000000000..8a2a22db8c
--- /dev/null
+++ b/testing/hub/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Eivind Uggedal <eivind@uggedal.com>
+# Maintainer
+pkgname=hub
+pkgver=2.2.3
+pkgrel=0
+pkgdesc="Extends git with extra features for GitHub"
+url="http://hub.github.com/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="go bash"
+install=""
+options="!strip"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/github/hub/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir" && ./script/build
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -D -m644 man/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ install -Dm644 "$builddir"/etc/hub.bash_completion.sh \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir"/etc/$pkgname.zsh_completion \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname || return 1
+}
+
+md5sums="6675992ddd16d186eac7ba4484d57f5b hub-2.2.3.tar.gz"
+sha256sums="f8a43df60b2efd95c70054324e73f27c3b253ec1c4969de8ea6c514669c688ed hub-2.2.3.tar.gz"
+sha512sums="6f05b697ea4aa4962ac2977e2060e418a7332756c713828ec987aad6c06b6cfb9f39c2ed79797f6c2243f841cd009344482a341d11c14fd4728ba4b8cc0318d5 hub-2.2.3.tar.gz"