aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-25 10:16:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-25 10:16:09 +0000
commitf70f846231ba36b7b95a837e526f865c2a272b37 (patch)
treeda8f08d0c6b6240d8204d7064c43ae57a8689749 /testing
parent37f740f2cae02c838be853145ee91666baead2af (diff)
downloadaports-f70f846231ba36b7b95a837e526f865c2a272b37.tar.bz2
aports-f70f846231ba36b7b95a837e526f865c2a272b37.tar.xz
community/libwmf: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/libwmf/APKBUILD36
-rw-r--r--testing/libwmf/libpng14.patch12
2 files changed, 0 insertions, 48 deletions
diff --git a/testing/libwmf/APKBUILD b/testing/libwmf/APKBUILD
deleted file mode 100644
index 412667ffef..0000000000
--- a/testing/libwmf/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=libwmf
-pkgver=0.2.8.4
-pkgrel=3
-pkgdesc="A library for reading vector images in Microsoft's native Windows Metafile Format (WMF)."
-url="http://wvware.sourceforge.net/libwmf.html"
-arch="all"
-license="LGPL"
-makedepends="libpng-dev>=1.4.0 freetype-dev jpeg-dev>=8 expat-dev"
-install=
-subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/sourceforge/wvware/$pkgname-$pkgver.tar.gz
- libpng14.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- patch -Np1 -i ""$srcdir"/libpng14.patch" || return 1
- sed -i -e 's/src include fonts doc/src include fonts/g' Makefile.in
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --with-gsfontdir=/usr/share/fonts/Type1 \
- --with-fontdir=/usr/share/fonts/Type1 \
- --with-gsfontmap=/usr/share/ghostscript/8.15/lib/Fontmap.GS
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
-}
-md5sums="d1177739bf1ceb07f57421f0cee191e0 libwmf-0.2.8.4.tar.gz
-33d3c07a1be9f99fd88de220930c5550 libpng14.patch"
diff --git a/testing/libwmf/libpng14.patch b/testing/libwmf/libpng14.patch
deleted file mode 100644
index 3d38c717aa..0000000000
--- a/testing/libwmf/libpng14.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur libwmf-0.2.8.4.orig/src/extra/gd/gd_png.c libwmf-0.2.8.4/src/extra/gd/gd_png.c
---- libwmf-0.2.8.4.orig/src/extra/gd/gd_png.c 2005-07-27 23:35:06.000000000 +0300
-+++ libwmf-0.2.8.4/src/extra/gd/gd_png.c 2010-01-17 01:33:58.000000000 +0200
-@@ -136,7 +136,7 @@
- /* first do a quick check that the file really is a PNG image; could
- * have used slightly more general png_sig_cmp() function instead */
- gdGetBuf (sig, 8, infile);
-- if (!png_check_sig (sig, 8))
-+ if (png_sig_cmp (sig, 0, 8))
- return NULL; /* bad signature */
-
- #ifndef PNG_SETJMP_NOT_SUPPORTED