aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-04-28 10:07:05 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-04-28 10:07:10 +0200
commit105a637d5ba72c78ad6d0ee5a3f08800d2a22680 (patch)
tree3434ce6e9e840073885d14c4d3b3169028e0244e /testing
parente635967684ca198be43daa7efdd44528f823a804 (diff)
downloadaports-105a637d5ba72c78ad6d0ee5a3f08800d2a22680.tar.bz2
aports-105a637d5ba72c78ad6d0ee5a3f08800d2a22680.tar.xz
testing/kimchi: enable build
Diffstat (limited to 'testing')
-rw-r--r--testing/kimchi/APKBUILD61
1 files changed, 50 insertions, 11 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index 83da72802e..508baa1cf4 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -5,24 +5,63 @@ pkgver=2.4.0
pkgrel=0
pkgdesc="An HTML5 management interface for KVM "
url="https://github.com/kimchi-project/kimchi"
-arch=""
+arch="noarch"
license="APACHE LGPL2.1"
-depends="python2 py-ipaddr py2-m2crypto py2-simplejson py-psutil
- py-imaging py2-libvirt py-cheetah py-ethtool py2-lxml py-websockify
- py2-pillow qemu py2-configobj py2-six py2-paramiko py2-magic libvirt-daemon
- wok gingerbase py2-netaddr py2-libuser
- util-linux spice-html5 websockify py-numpy"
-makedepends="automake autoconf libtool gettext-dev
- python2-dev py-setuptools pyflakes libxslt py2-pip
- py-pep8 py2-mock py-cherrypy pytest py2-requests
- grep bash bc spice-html5"
+depends="
+ python2
+ py-ipaddr
+ py2-m2crypto
+ py2-simplejson
+ py-psutil
+ py-imaging
+ py2-libvirt
+ py-cheetah
+ py-ethtool
+ py2-lxml
+ py-websockify
+ py2-pillow
+ qemu
+ py2-configobj
+ py2-six
+ py2-paramiko
+ py2-magic
+ libvirt-daemon
+ wok
+ gingerbase
+ py2-netaddr
+ py2-libuser
+ util-linux
+ spice-html5
+ websockify
+ py-numpy
+ "
+makedepends="
+ automake
+ autoconf
+ libtool
+
+ gettext-dev
+ python2-dev
+ py-setuptools
+ pyflakes
+ libxslt py2-pip
+ py-pep8
+ py2-mock
+ py-cherrypy
+ pytest
+ py2-requests
+ grep
+ bash
+ bc
+ spice-html5
+ "
options="!check"
subpackages="$pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
systemd-substitution-with-openrc.patch"
builddir="$srcdir/$pkgname-$pkgver"
-build() {
+build() {
cd "$builddir"
sh ./autogen.sh --system
./configure \