aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-06 11:15:20 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-11-06 11:42:26 +0100
commit11ef1b7d2634e4f3821c4be467be4be6bccf0bc4 (patch)
tree1e85c5978765ea6a9e9acbe4e295763325af81ad /testing
parent981dae5d3d081ad67209489592421e214255d934 (diff)
downloadaports-11ef1b7d2634e4f3821c4be467be4be6bccf0bc4.tar.bz2
aports-11ef1b7d2634e4f3821c4be467be4be6bccf0bc4.tar.xz
testing/gwenhywfar: add check()
Diffstat (limited to 'testing')
-rw-r--r--testing/gwenhywfar/APKBUILD12
-rw-r--r--testing/gwenhywfar/fix-tests.patch23
2 files changed, 32 insertions, 3 deletions
diff --git a/testing/gwenhywfar/APKBUILD b/testing/gwenhywfar/APKBUILD
index 45b7a401dd..2be05a3e56 100644
--- a/testing/gwenhywfar/APKBUILD
+++ b/testing/gwenhywfar/APKBUILD
@@ -3,7 +3,7 @@
pkgname=gwenhywfar
pkgver=4.15.3
_pkgrel=201
-pkgrel=1
+pkgrel=2
pkgdesc="Multi-platform helper library"
url="http://www.aquamaniac.de/"
arch="all"
@@ -15,7 +15,8 @@ makedepends="libgcrypt-dev gnutls-dev gettext-dev
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://www.aquamaniac.de/sites/download/download.php?package=01&release=${_pkgrel}&file=01&dummy=$pkgname-$pkgver.tar.gz
- libintl.patch"
+ libintl.patch
+ fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -39,6 +40,10 @@ build() {
make
}
+check() {
+ make -C "$builddir" check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
@@ -49,4 +54,5 @@ package() {
}
sha512sums="a14d625518d94c94491df149f9e746ed8d769f4e43b6df24f51f4269f29005f7431e33e85de0bde0a81a2e876fea8ddad5ed4191114295d6c9ea2e94aba08799 gwenhywfar-4.15.3.tar.gz
-fcccf5aa3872f4327205c3c77c5e1b88fbce89d6fe45330f72a38c207b7f6166ca486e70636119a9c16447a3c09e3bad97ed7a1cc5f06db53939f510e2c19cca libintl.patch"
+fcccf5aa3872f4327205c3c77c5e1b88fbce89d6fe45330f72a38c207b7f6166ca486e70636119a9c16447a3c09e3bad97ed7a1cc5f06db53939f510e2c19cca libintl.patch
+62a127684b5d0900edf3f78b884285e63ea43d076b03c265cb59834e915fb68be61601bd54a6c991b20e793d511a5826fde22312e3fe3b2686d993cf32dd3869 fix-tests.patch"
diff --git a/testing/gwenhywfar/fix-tests.patch b/testing/gwenhywfar/fix-tests.patch
new file mode 100644
index 0000000000..00051f551b
--- /dev/null
+++ b/testing/gwenhywfar/fix-tests.patch
@@ -0,0 +1,23 @@
+Port 443 is not open on devel.aqbanking.de connect to google.com instead.
+
+diff -upr gwenhywfar-4.18.0.orig/checks/syncio_https.c gwenhywfar-4.18.0/checks/syncio_https.c
+--- gwenhywfar-4.18.0.orig/checks/syncio_https.c 2017-11-06 11:35:39.376537746 +0100
++++ gwenhywfar-4.18.0/checks/syncio_https.c 2017-11-06 11:36:01.173317776 +0100
+@@ -33,7 +33,7 @@ static int check_syncio_https1() {
+ "ERROR in check_syncio_http1: Could not create socket io layer.\n");
+ return 2;
+ }
+- GWEN_SyncIo_Socket_SetAddress(sio, "devel.aqbanking.de");
++ GWEN_SyncIo_Socket_SetAddress(sio, "google.com");
+ GWEN_SyncIo_Socket_SetPort(sio, 443);
+
+ baseLayer=sio;
+@@ -82,7 +82,7 @@ static int check_syncio_https1() {
+ GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "url", "/index.html");
+
+ db=GWEN_SyncIo_Http_GetDbHeaderOut(sio);
+- GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Host", "devel.aqbanking.de");
++ GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Host", "google.com");
+ GWEN_DB_SetIntValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Content-length", 0);
+ GWEN_DB_SetCharValue(db, GWEN_DB_FLAGS_OVERWRITE_VARS, "Connection", "close");
+