aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-11-27 15:58:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-27 15:59:03 +0000
commit1f69ca14eecea17f2f2f8a80420cc62c2028a813 (patch)
treed0e388a719f333af24fa02cb0ed39d116fc24ad7 /testing
parent5428f25210142e0f749690023cf40e2fd6a8b623 (diff)
downloadaports-1f69ca14eecea17f2f2f8a80420cc62c2028a813.tar.bz2
aports-1f69ca14eecea17f2f2f8a80420cc62c2028a813.tar.xz
testing/apache2-mod-perl: rebuild against perl 5.26. Added check()
Diffstat (limited to 'testing')
-rw-r--r--testing/apache2-mod-perl/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/testing/apache2-mod-perl/APKBUILD b/testing/apache2-mod-perl/APKBUILD
index 7cfb23981f..78d71540f6 100644
--- a/testing/apache2-mod-perl/APKBUILD
+++ b/testing/apache2-mod-perl/APKBUILD
@@ -4,7 +4,7 @@
pkgname=apache2-mod-perl
_pkgreal=mod_perl
pkgver=2.0.10
-pkgrel=0
+pkgrel=1
pkgdesc="Perl Module for Apache2"
url="http://perl.apache.org/"
arch="all"
@@ -12,7 +12,6 @@ license="ASL 2.0"
depends="apache2"
depends_dev="$pkgname"
makedepends="apache2-dev perl-dev perl-linux-pid apr-dev apr-util-dev"
-install=""
subpackages="$pkgname-doc $pkgname-dev"
source="http://www-eu.apache.org/dist/perl/$_pkgreal-$pkgver.tar.gz
$pkgname.conf"
@@ -22,27 +21,33 @@ build() {
cd "$builddir"
perl Makefile.PL \
INSTALLDIRS=vendor \
- MP_APXS=/usr/bin/apxs || return 1
- make || return 1
+ MP_APXS=/usr/bin/apxs
+ make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
+
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
install -Dm644 "$srcdir"/$pkgname.conf \
"$pkgdir"/etc/apache2/conf.d/$_pkgreal.conf
}
dev() {
- default_dev || return 1
+ default_dev
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr || return 1
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
- mkdir -p "$subpkgdir"/usr/lib/perl5/vendor_perl/auto/Apache2 || return 1
+ mkdir -p "$subpkgdir"/usr/lib/perl5/vendor_perl/auto/Apache2
mv "$pkgdir"/usr/lib/perl5/vendor_perl/auto/Apache2/Build \
"$pkgdir"/usr/lib/perl5/vendor_perl/auto/Apache2/typemap \
- "$subpkgdir"/usr/lib/perl5/vendor_perl/auto/Apache2 ||return 1
+ "$subpkgdir"/usr/lib/perl5/vendor_perl/auto/Apache2
}
md5sums="cef55e715b5770a63b3becbe9d271121 mod_perl-2.0.10.tar.gz