aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-06 20:06:30 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-06 20:06:30 +0000
commit53bc9e888f15da67773b902cd04f9729615a04d5 (patch)
tree909e6a097540d203bc04a7737e17a5df68eddaa0 /testing
parenta14600015b1965e2c3815c1e259a6daaab5fdf7c (diff)
downloadaports-53bc9e888f15da67773b902cd04f9729615a04d5.tar.bz2
aports-53bc9e888f15da67773b902cd04f9729615a04d5.tar.xz
Revert "community/texmf-dist: move from testing"
Diffstat (limited to 'testing')
-rw-r--r--testing/texmf-dist/APKBUILD43
-rw-r--r--testing/texmf-dist/texmf-dist.trigger4
2 files changed, 47 insertions, 0 deletions
diff --git a/testing/texmf-dist/APKBUILD b/testing/texmf-dist/APKBUILD
new file mode 100644
index 0000000000..593683f409
--- /dev/null
+++ b/testing/texmf-dist/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=texmf-dist
+pkgver=2017.44907
+pkgrel=1
+pkgdesc="TeX Live texmf core distribution"
+url="http://tug.org/texlive/"
+arch="noarch"
+license="GPL"
+depends="texlive"
+depends_dev=""
+makedepends="texlive-full xz"
+install=""
+subpackages="${pkgname}-most"
+source="${pkgname}-${pkgver}.tar.xz::https://github.com/maribu/${pkgname}/raw/master/${pkgname}-${pkgver}.tar.xz
+ ${pkgname}-most-${pkgver}.tar.xz::https://github.com/maribu/${pkgname}/raw/master/${pkgname}-most-${pkgver}.tar.xz"
+options="!check"
+triggers="texmf-dist.trigger=/usr/share/texmf-dist"
+unpack() {
+ # Prevent unpacking by overwriting the unpack() function
+ return 0
+}
+
+build(){
+ return 0
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share"
+ cd "${pkgdir}/usr/share"
+ tar xJf "${srcdir}/${pkgname}-${pkgver}.tar.xz"
+}
+
+most() {
+ pkgdesc="TeX Live texmf distribution including most of the TeX Live distribution"
+ depends="${pkgname}"
+ mkdir -p "${subpkgdir}/usr/share"
+ cd "${subpkgdir}/usr/share"
+ tar xJf "${srcdir}/${pkgname}-most-${pkgver}.tar.xz"
+}
+
+sha512sums="9d08aa5850f89bd7a1327a0a2e4aef117ea05cc71d074fc95d3cba4494414426124976703b85c5a2d58b4358d74e9f23bd97b5668c6fa872acf4daf9fb92be27 texmf-dist-2017.44907.tar.xz
+c53926b9a9c1092a35cc1d32593ab46828877ab2faf4f582910a62bda7de6f81d9db61b5c508e768c68a80fa7a0c6470b05f3114a8ff98512fe811198230a8cd texmf-dist-most-2017.44907.tar.xz"
diff --git a/testing/texmf-dist/texmf-dist.trigger b/testing/texmf-dist/texmf-dist.trigger
new file mode 100644
index 0000000000..d549354929
--- /dev/null
+++ b/testing/texmf-dist/texmf-dist.trigger
@@ -0,0 +1,4 @@
+#!/bin/sh
+texhash
+fmtutil-sys --all
+exit 0