aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-28 22:52:38 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-28 23:06:26 +0000
commit588d7cff2cdf48d6b4ea30be01eef2558f7043a8 (patch)
tree9777bf5bc8f1417f1feb02e1ab9947a33c3f4115 /testing
parentccd9222baad080f8d6450538d0cadbb549e094a4 (diff)
downloadaports-588d7cff2cdf48d6b4ea30be01eef2558f7043a8.tar.bz2
aports-588d7cff2cdf48d6b4ea30be01eef2558f7043a8.tar.xz
testing/unifont: new Aport
Adding this new package, that will be required for grub2, mainly for grub-mkrescue. Adding this package for ppc64le only at this moment.
Diffstat (limited to 'testing')
-rw-r--r--testing/unifont/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/unifont/APKBUILD b/testing/unifont/APKBUILD
new file mode 100644
index 0000000000..2c212898da
--- /dev/null
+++ b/testing/unifont/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Breno Leitao <breno.leitao@gmail.com>
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=unifont
+pkgver=9.0.06
+pkgrel=0
+pkgdesc="GNU Unifont package with glyphs for every printable code point in the Unicode 9.0 Basic Multilingual Plane (BMP)"
+url="http://unifoundry.com/pub/unifont-9.0.06/unifont-9.0.06.tar.gz"
+arch="ppc64le"
+license="GPL"
+depends="bdftopcf perl-gd"
+makedepends=""
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://unifoundry.com/pub/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ # The make file is not parallel, and crash.
+ # Should force the build in serial mode!
+ DESTDIR=/usr make -j1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="767dc107d9a33008116b6939facbf31db6c7942acad257ad52a1a249f04b6215b41da928ef00e8308c2cc19924257cb0219d4eddd2b99502621ebd82e8673988 unifont-9.0.06.tar.gz"