aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-28 14:02:00 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-28 14:02:00 +0000
commit5c090d6b334c062bb727100e68012fc752d1368a (patch)
tree7857ef7d291d92f5d80f9467199664d353660547 /testing
parent0e437185c1925adfb78ba92e8e06b37397c5d0ec (diff)
downloadaports-5c090d6b334c062bb727100e68012fc752d1368a.tar.bz2
aports-5c090d6b334c062bb727100e68012fc752d1368a.tar.xz
testing/harminv: add check function
Diffstat (limited to 'testing')
-rw-r--r--testing/harminv/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/harminv/APKBUILD b/testing/harminv/APKBUILD
index dbd6ef63cb..ee1c385bb7 100644
--- a/testing/harminv/APKBUILD
+++ b/testing/harminv/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=harminv
pkgver=1.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="Free program to solve the problem of harmonic inversion"
url="https://github.com/stevengj/harminv"
arch="all"
@@ -28,6 +28,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install