aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-11-14 12:22:15 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-15 09:37:11 +0000
commit6364b4a020cba0999d864983c509aab847bcd473 (patch)
tree0598c241a858331004b2c3f466f936691116051e /testing
parent2ab5e9d1b14bc0c683cfb2bd367eaf67636daeb8 (diff)
downloadaports-6364b4a020cba0999d864983c509aab847bcd473.tar.bz2
aports-6364b4a020cba0999d864983c509aab847bcd473.tar.xz
testing/astyle: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/astyle/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/astyle/APKBUILD b/testing/astyle/APKBUILD
new file mode 100644
index 0000000000..6796ff37a0
--- /dev/null
+++ b/testing/astyle/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=astyle
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="An automatic code formatter"
+url="http://sourceforge.net/projects/astyle"
+arch="all"
+license="LGPL"
+source="http://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz"
+builddir="$srcdir/$pkgname/build/gcc"
+
+build() {
+ cd "$builddir"
+ make release
+}
+
+check() {
+ cd "$builddir"
+ # upstream do not provide tests
+ ./bin/astyle --version
+}
+
+package() {
+ cd "$builddir"
+ install -Dm0755 bin/astyle "$pkgdir/usr/bin/astyle"
+}
+
+sha512sums="3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158 astyle_3.0.1_linux.tar.gz"