aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-30 23:12:03 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-30 23:14:49 +0000
commit735b9096d28dbe3e41475cdc6aafb051c6ebf224 (patch)
tree03eeea041764d6539f40405048e3a85521286ff3 /testing
parent3be52b301dc83d65d4bdbfac7c2fe3585484cd11 (diff)
downloadaports-735b9096d28dbe3e41475cdc6aafb051c6ebf224.tar.bz2
aports-735b9096d28dbe3e41475cdc6aafb051c6ebf224.tar.xz
testing/ceph: enable build on ppc64le
The patch applied downstream is already merged upstream at: https://github.com/ceph/ceph/pull/18615
Diffstat (limited to 'testing')
-rw-r--r--testing/ceph/APKBUILD10
-rw-r--r--testing/ceph/make-sure-PATH_MAX-is-defined.patch19
2 files changed, 24 insertions, 5 deletions
diff --git a/testing/ceph/APKBUILD b/testing/ceph/APKBUILD
index eef6bb787a..ecb8ce0bc7 100644
--- a/testing/ceph/APKBUILD
+++ b/testing/ceph/APKBUILD
@@ -10,7 +10,7 @@ pkgdesc="User space components of the Ceph file system"
pkgusers="ceph"
pkggroups="ceph"
url="http://ceph.com"
-arch="x86_64"
+arch="x86_64 ppc64le"
license="LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and GPL-2.0-with-autoconf-exception and BSD-3-Clause and MIT"
depends="ceph-osd ceph-mds ceph-mon"
@@ -65,7 +65,8 @@ makedepends="
"
#source="$pkgname-$pkgver.tar.gz::https://github.com/ceph/ceph/archive/v$pkgver.tar.gz"
-source="https://github.com/dx9/ceph/releases/download/11.0.1/ceph-$pkgver-beta1.tar.bz2"
+source="https://github.com/dx9/ceph/releases/download/11.0.1/ceph-$pkgver-beta1.tar.bz2
+ make-sure-PATH_MAX-is-defined.patch"
subpackages="
$pkgname-base
@@ -516,6 +517,5 @@ bash_completion() {
mkdir -p "$subpkgdir"$_sysconfdir/bash_completion.d
mv "$pkgdir"$_sysconfdir/bash_completion.d/* "$subpkgdir"$_sysconfdir/bash_completion.d
}
-md5sums="edae3d83b4dd0f1316bdc0799ea61769 ceph-11.0.1-beta1.tar.bz2"
-sha256sums="fedaff78cd590021087edf168c0649505880cfbd73cde4029933b823f5ac617f ceph-11.0.1-beta1.tar.bz2"
-sha512sums="d8bc28a25b9444134527f22856a6f0ea97b21a6100b0576a092d8988da0f191aca1e59bd14129361aee53f3032295169117ff02207e2ff361bb526461b9c5462 ceph-11.0.1-beta1.tar.bz2"
+sha512sums="d8bc28a25b9444134527f22856a6f0ea97b21a6100b0576a092d8988da0f191aca1e59bd14129361aee53f3032295169117ff02207e2ff361bb526461b9c5462 ceph-11.0.1-beta1.tar.bz2
+a1843f78a2fa68d1a77e3b3c90581d5a96fb378267216584b2668fb4143ddaa4cd5c9d66ff2135aff44d488bca7a0cad23a8b3d782bd01342e515e3ec7c6403d make-sure-PATH_MAX-is-defined.patch"
diff --git a/testing/ceph/make-sure-PATH_MAX-is-defined.patch b/testing/ceph/make-sure-PATH_MAX-is-defined.patch
new file mode 100644
index 0000000000..0726359899
--- /dev/null
+++ b/testing/ceph/make-sure-PATH_MAX-is-defined.patch
@@ -0,0 +1,19 @@
+From 972c34465d1f78cc2e2ebe53192905d378c1541e Mon Sep 17 00:00:00 2001
+From: Roberto Oliveira <robertoguimaraes8@gmail.com>
+Date: Sun, 29 Oct 2017 14:05:48 +0000
+Subject: [PATCH] rbd-fuse: make sure PATH_MAX is defined
+
+On systems without glibc, as Alpine Linux, you might lack definition of
+PATH_MAX. This patch adds the limits.h header to solve this issue.
+
+Signed-off-by: Roberto Oliveira <robertoguimaraes8@gmail.com>
+--- a/src/rbd_fuse/rbd-fuse.cc
++++ b/src/rbd_fuse/rbd-fuse.cc
+@@ -19,6 +19,7 @@
+ #include <getopt.h>
+ #include <assert.h>
+ #include <string>
++#include <limits.h>
+
+ #if defined(__FreeBSD__)
+ #include <sys/param.h>