aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-27 11:21:05 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-27 11:21:08 +0000
commit8db25d5fa1aaafe794536ed073f8c6b938c8147f (patch)
treef29b5b30af322e405a3c6574ac0024897c53450c /testing
parenta83006205d14a16ab0d7e365a803c59213db529d (diff)
downloadaports-8db25d5fa1aaafe794536ed073f8c6b938c8147f.tar.bz2
aports-8db25d5fa1aaafe794536ed073f8c6b938c8147f.tar.xz
testing/yara: fix test failure
Delete re_lexer.c file to force it to be build with new version of flex, othwewise tests fail in some arches because of a bug in older version of flex. See: https://github.com/VirusTotal/yara/issues/771
Diffstat (limited to 'testing')
-rw-r--r--testing/yara/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/testing/yara/APKBUILD b/testing/yara/APKBUILD
index a54b0857ef..e660ebabda 100644
--- a/testing/yara/APKBUILD
+++ b/testing/yara/APKBUILD
@@ -7,11 +7,19 @@ pkgdesc="The pattern matching swiss knife for malware researchers"
url="https://virustotal.github.io/yara/"
arch="all"
license="BSD-3-Clause"
-makedepends="automake file-dev libressl-dev autoconf libtool"
+makedepends="automake file-dev libressl-dev autoconf libtool flex"
source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/$pkgname/archive/v$pkgver.tar.gz"
subpackages="$pkgname-doc"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ # Delete re_lexer.c to force it to be build with new version
+ # of flex, othwewise tests fail in some arches because of a bug
+ # in older version of flex.
+ # See: https://github.com/VirusTotal/yara/issues/771
+ rm "$srcdir"/yara-3.6.3/libyara/re_lexer.c
+}
build() {
cd "$builddir"
autoreconf -fiv