aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-28 13:41:33 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-10-28 13:41:35 +0000
commita24b5e689719a86e0bbb9377cf16b3ccfc79291d (patch)
treee1f58cdcdd5367e2c8df24b084fb93e5b7b4272d /testing
parent2808e15ddeab497ab7df27afa8a22022e7fa26c0 (diff)
downloadaports-a24b5e689719a86e0bbb9377cf16b3ccfc79291d.tar.bz2
aports-a24b5e689719a86e0bbb9377cf16b3ccfc79291d.tar.xz
testing/googler: add check function
As upstream doesn't provide a suite test, run --help to test if the binary works.
Diffstat (limited to 'testing')
-rw-r--r--testing/googler/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/googler/APKBUILD b/testing/googler/APKBUILD
index c498c76ab9..b1297babbb 100644
--- a/testing/googler/APKBUILD
+++ b/testing/googler/APKBUILD
@@ -17,6 +17,11 @@ build() {
make disable-self-upgrade
}
+check() {
+ cd "$builddir"
+ googler --help > /dev/null
+}
+
package() {
cd "$builddir"
make install DESTDIR="$pkgdir" PREFIX=/usr