aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-18 01:06:39 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-18 01:07:06 +0100
commita85071ef2f138bae7315b6776a18886319abf9cf (patch)
tree329f9f8fbee44ec707769e296cd63ce8522b492a /testing
parent88b05a1a15de851dd517e7f5014ecad4514665c1 (diff)
downloadaports-a85071ef2f138bae7315b6776a18886319abf9cf.tar.bz2
aports-a85071ef2f138bae7315b6776a18886319abf9cf.tar.xz
testing/esh: new aport
https://github.com/jirutka/esh Simple template system based on shell
Diffstat (limited to 'testing')
-rw-r--r--testing/esh/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/esh/APKBUILD b/testing/esh/APKBUILD
new file mode 100644
index 0000000000..5a31575971
--- /dev/null
+++ b/testing/esh/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=esh
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Simple template system based on shell"
+url="https://github.com/jirutka/esh"
+arch="noarch"
+license="MIT"
+checkdepends="asciidoctor"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install
+}
+
+sha512sums="79b9e66f7991f7e4d64557367a8fec5698c2efc9454bab644206fc14aed6b829973a2d475d6117c34a2ed9f86472075abbb49eaef04e88d719579a29f90449b8 esh-0.1.0.tar.gz"