aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-02 09:21:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-02 09:22:23 +0000
commitaee43924630c2900d2aac26e35acfc22d38ea578 (patch)
tree636157e64cc7ebd85f3429709fcebbb44d7b17ce /testing
parent9331f94d9d89dfba9b93caf9d4ce178ba7ea0b41 (diff)
downloadaports-aee43924630c2900d2aac26e35acfc22d38ea578.tar.bz2
aports-aee43924630c2900d2aac26e35acfc22d38ea578.tar.xz
testing/lua-ossl: new aport
comprehensive OpenSSL Lua module http://25thandclement.com/~william/projects/luaossl.html
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-ossl/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/lua-ossl/APKBUILD b/testing/lua-ossl/APKBUILD
new file mode 100644
index 0000000000..63dd2f5b99
--- /dev/null
+++ b/testing/lua-ossl/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=lua-ossl
+pkgver=20140322
+pkgrel=0
+pkgdesc="comprehensive OpenSSL Lua module"
+url="http://25thandclement.com/~william/projects/luaossl.html"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev lua5.2-dev openssl-dev"
+install=""
+subpackages=""
+source="luaossl-$pkgver.tar.gz::https://github.com/wahern/luaossl/archive/rel-$pkgver.tar.gz"
+
+_builddir="$srcdir"/luaossl-rel-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make config prefix=/usr || return 1
+ make openssl5.2 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install5.2 || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="d3c539499c0ff0b977d4fcfddf62da25 luaossl-20140322.tar.gz"
+sha256sums="b5e3e4426a08ec9874c47d406f4a562ca34748df2bbf0130e39418780364c40b luaossl-20140322.tar.gz"
+sha512sums="d4cb9af2cc42e707bac8031fff58345ae426688b4adceda77501ce581a8fb4901de07d6bf8ec9be655534e4f9501d932eb103847fe170d9da577e7d9fd8b87fd luaossl-20140322.tar.gz"