aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-18 17:26:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-18 17:26:32 +0000
commitda422d63cf72f05137326de21e931e64108f9636 (patch)
tree8b8e3d1d0e39009f1f49eb8360faf66333019031 /testing
parent2ce356292507a5ccfff852efb2a97c2589f4f8e4 (diff)
downloadaports-da422d63cf72f05137326de21e931e64108f9636.tar.bz2
aports-da422d63cf72f05137326de21e931e64108f9636.tar.xz
main/statserial: moved from testing
ref #1533
Diffstat (limited to 'testing')
-rw-r--r--testing/statserial/APKBUILD46
-rw-r--r--testing/statserial/makefile.patch11
-rw-r--r--testing/statserial/statserial-1.patch10
-rw-r--r--testing/statserial/statserial-c.patch20
4 files changed, 0 insertions, 87 deletions
diff --git a/testing/statserial/APKBUILD b/testing/statserial/APKBUILD
deleted file mode 100644
index d3af9c6e13..0000000000
--- a/testing/statserial/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-pkgname=statserial
-pkgver=1.1
-pkgrel=1
-pkgdesc="Display serial port modem status lines"
-url="http://sunsite.unc.edu/pub/Linux/system/Serial"
-arch="all"
-license="GPL"
-depends=""
-depends_dev="ncurses-dev"
-makedepends="$depends_dev"
-install=""
-subpackages=""
-source="ftp://metalab.unc.edu/pub/Linux/system/serial/statserial-1.1.tar.gz
- statserial-1.patch
- statserial-c.patch
- makefile.patch
- "
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- sed -i -e "s/\/local//" Makefile
-}
-
-build() {
- cd "$_builddir"
- make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" CC="${CC:-gcc}" || return 1
-}
-
-package() {
- cd "$_builddir"
- mkdir -p $pkgdir/usr/bin
- install -m755 $pkgname $pkgdir/usr/bin/$pkgname
-}
-
-md5sums="bcd90fb0881c64024396bf1070de7e64 statserial-1.1.tar.gz
-e59a2c9bdc4e367f7720ae38f363b152 statserial-1.patch
-6762523b1786ad7c52f9c2263023eedd statserial-c.patch
-b8d7c2d254a2266e3ece7e2c3be69d31 makefile.patch"
diff --git a/testing/statserial/makefile.patch b/testing/statserial/makefile.patch
deleted file mode 100644
index 18284b0511..0000000000
--- a/testing/statserial/makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- statserial-1.1.orig/Makefile
-+++ statserial-1.1/Makefile
-@@ -7,7 +7,7 @@
-
- # for production code
- CFLAGS = -Wall -O3 -fomit-frame-pointer
--LDFLAGS = -s -N
-+LDFLAGS = -s
-
- statserial: statserial.o
- $(LD) $(LDFLAGS) -o statserial statserial.o -lcurses
diff --git a/testing/statserial/statserial-1.patch b/testing/statserial/statserial-1.patch
deleted file mode 100644
index 19f85f03dd..0000000000
--- a/testing/statserial/statserial-1.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- statserial-1.1.orig/statserial.1
-+++ statserial-1.1/statserial.1
-@@ -5,7 +5,6 @@
- .\" for conditions under which this file may be redistributed.
- .TH STATSERIAL 1 "17 December 1994" "Linux" "User Commands"
- .SH NAME
--
- statserial \- display serial port modem status lines
-
- .SH SYNOPSIS
diff --git a/testing/statserial/statserial-c.patch b/testing/statserial/statserial-c.patch
deleted file mode 100644
index 448a6b0b62..0000000000
--- a/testing/statserial/statserial-c.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- statserial-1.1.orig/statserial.c
-+++ statserial-1.1/statserial.c
-@@ -42,7 +42,7 @@
-
- /* global variables */
- char device[255]; /* name of device to open */
--const char *defaultDevice = "/dev/cua1"; /* default device if none specified on command line */
-+const char *defaultDevice = "/dev/ttyS1"; /* default device if none specified on command line */
- int n_option = 0; /* set if -n option is used */
- int d_option = 0; /* set if -d option is used */
- int x_option = 0; /* set if -x option is used */
-@@ -118,7 +118,7 @@
- parse_args(argc, argv);
-
- /* open port */
-- fd = open(device, O_RDONLY);
-+ fd = open(device, O_RDONLY | O_NONBLOCK | O_NOCTTY);
- if (fd == -1) {
- char s[255];
- sprintf(s, "statserial: can't open device `%s'", device);